CLEVER - HTML5 Radio Player With History - Shoutcast and Icecast - Elementor Widget Addon…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-73 and the CVSS impact.
Summary
The CLEVER - HTML5 Radio Player With History - Shoutcast and Icecast - Elementor Widget Addon plugin for WordPress is vulnerable to arbitrary file read due to insufficient file path validation in the 'history.php' file in all versions up to, and including, 2.4. This makes it possible for unauthenticated attackers to read arbitrary files on the affected site's server, which may contain sensitive information including database credentials. The vulnerability was partially patched in version 2.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| LambertGroup | CLEVER - HTML5 Radio Player With History - Shoutcast and Icecast - Elementor Widget Addon | up to 2.4 | — | No fix listed | CNA |
- CLEVER - HTML5 Radio Player With History - Shoutcast and Icecast - Elementor Widget Addon VendorLambertGroup Affected up to 2.4 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3103
- 2026-10-03 Alias added: GHSA-cgf8-4346-5g89
References
More LambertGroup vulnerabilities
- TI-2025-22798 WordPress CLEVER plugin <= 2.6 - Arbitrary File Download Vulnerability CVSS 3.1HIGH 7.5
- TI-2025-22340 WordPress HTML5 Radio Player - WPBakery Page Builder Addon plugin <= 2.5 - Arbitrary File Download vulnerability CVSS 3.1HIGH 7.5
- TI-2025-41662 WordPress xPromoter plugin <= 1.3.4 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2025-41272 WordPress Accordion Slider PRO plugin <= 1.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2025-38416 WordPress Image&Video FullScreen Background plugin <= 1.6.7 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
- TI-2025-23404 WordPress Chameleon HTML5 Audio Player With/Without Playlist plugin <= 3.5.6 - SQL Injection Vulnerability CVSS 3.1HIGH 8.5
Sources
- CVE-2025-3103 · CVE Program
- CVE-2025-3103 · NVD
- FIRST EPSS
- GHSA-cgf8-4346-5g89 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences