Read the docs
TI-2025-02733 Aliases CVE-2025-3130GHSA-hphm-3x7f-g875

Obfuscate - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-029

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Obfuscate allows Stored XSS.This issue affects Obfuscate: from 0.0.0 before 2.0.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0024 15th percentileScored 2026-11-07
Fix Fixed Obfuscate (Drupal): 2.0.1drupal/obfuscate (Packagist): 2.0.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalObfuscate0.0.0 to before 2.0.12.0.1Patch availableCNA
—drupal/obfuscate (Packagist)before 2.0.12.0.1Patch availableGHSA-hphm-3x7f-g875
  • Obfuscate VendorDrupal Affected 0.0.0 to before 2.0.1 Fixed in 2.0.1 Patch available CNA
  • drupal/obfuscate (Packagist) Vendor— Affected before 2.0.1 Fixed in 2.0.1 Patch available GHSA-hphm-3x7f-g875

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:obfuscate:*:*:*:*:*:drupal:*:*before 2.0.1VulnerableDrupal
  • cpe:2.3:a:drupal:obfuscate:*:*:*:*:*:drupal:*:* Versions before 2.0.1 Vulnerable ·Drupal

Remediation

  • Fix · CNA Obfuscate (Drupal) Fixed in 2.0.1
  • Fix · GHSA-hphm-3x7f-g875 drupal/obfuscate (Packagist) Fixed in 2.0.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-3130
  2. 2026-10-03 Alias added: GHSA-hphm-3x7f-g875

References

Sources