Langflow < 1.3.0 Unauthenticated RCE via /api/v1/validate/code
Priority CRITICAL 100Exploited in the wildCWE-306Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-306 and CWE-94.
Summary
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.
Why it matters now
Exploitation Active In CISA KEV since 2025-05-05CISA due date 2025-05-26Known ransomware use
EPSS 0.99993 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed langflow (langflow-ai): 1.3.0langflow (PyPI): 1.3.0+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Langflow | langflow | before 1.3.0 | 1.3.0 | Patch available | CNA |
| — | langflow (PyPI) | before 1.3.0 | 1.3.0 | Patch available | GHSA-rvqx-wpfh-mfx7 |
| — | langflow-base (PyPI) | before 0.3.0 | 0.3.0 | Patch available | GHSA-rvqx-wpfh-mfx7 |
- langflow VendorLangflow Affected before 1.3.0 Fixed in 1.3.0 Patch available CNA
- langflow (PyPI) Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available GHSA-rvqx-wpfh-mfx7
- langflow-base (PyPI) Vendor— Affected before 0.3.0 Fixed in 0.3.0 Patch available GHSA-rvqx-wpfh-mfx7
Remediation
- Fix · CNA langflow (langflow-ai) Fixed in 1.3.0
- Fix · GHSA-rvqx-wpfh-mfx7 langflow (PyPI) Fixed in 1.3.0 Advisory →
- Fix · GHSA-rvqx-wpfh-mfx7 langflow-base (PyPI) Fixed in 0.3.0 Advisory →
Timeline
- 2025-05-05 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2025-3248
- 2026-10-03 Alias added: GHSA-rvqx-wpfh-mfx7
References
Other 8
- https://github.com/langflow-ai/langflow/releases/tag/1.3.0
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-rvqx-wpfh-mfx7
- https://github.com/langflow-ai/langflow/commit/faac4db133de32fcb6d483fa9ff52f40ce42bdc0
- https://github.com/langflow-ai/langflow
- https://github.com/pypa/advisory-database/tree/main/vulns/langflow-base/PYSEC-2026-380.yaml
- https://pypi.org/project/langflow-base
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-3248
- https://www.horizon3.ai/attack-research/disclosures/unsafe-at-any-speed-abusing-python-exec-for-unauth-rce-in-langflow-ai
More Langflow vulnerabilities
- TI-2026-08085 Unauthenticated Remote Code Execution via Auto-Login Bypass and Code Validation KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00553 Langflow exec_globals Inclusion of Functionality from Untrusted Control Sphere Remote… KEVCVSS 3.0CRITICAL 9.8
- TI-2025-24427 Langflow <= 1.6.9 CORS Misconfiguration to Token Hijack & RCE KEVCVSS 4.0CRITICAL 9.4
- TI-2026-25463 Langflow has Unauthenticated Remote Code Execution via Public Flow Build Endpoint KEVCVSS 4.0CRITICAL 9.3
- TI-2026-39928 Authorization bypass in langflow KEVCVSS 3.1HIGH 8.4
- TI-2026-22309 Langflow has Remote Code Execution in CSV Agent CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-3248 · CVE Program
- CVE-2025-3248 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-rvqx-wpfh-mfx7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences