FancyBox for WordPress < 3.3.6 - Unauthenticated Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The FancyBox for WordPress plugin before 3.3.6 does not escape captions and titles attributes before using them to populate galleries' caption fields. The issue was received as a Contributor+ Stored XSS, however one of our researcher (Marc Montpas) escalated it to an Unauthenticated Stored XSS
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00259 17th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed FancyBox for WordPress (Unknown): 3.3.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | FancyBox for WordPress | before 3.3.6 | 3.3.6 | Patch available | CNA |
- FancyBox for WordPress VendorUnknown Affected before 3.3.6 Fixed in 3.3.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:colorlib:fancybox:*:*:*:*:*:wordpress:*:* | before 3.3.6 | Vulnerable | colorlibplugins |
- cpe:2.3:a:colorlib:fancybox:*:*:*:*:*:wordpress:*:* Versions before 3.3.6 Vulnerable ·colorlibplugins
Remediation
- Fix · CNA FancyBox for WordPress (Unknown) Fixed in 3.3.6
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3662
- 2026-10-03 Alias added: GHSA-3q79-wmhj-39pr
References
More colorlibplugins Fancybox vulnerabilities
- TI-2015-01355 The FancyBox for WordPress plugin before 3.0.3 for WordPress does not properly restrict… CVSS 2.0MEDIUM 4.3
- TI-2024-00611 Cross-site scripting in colorlibplugins FancyBox for WordPress CVSS 3.1MEDIUM 4.8
Sources
- CVE-2025-3662 · CVE Program
- CVE-2025-3662 · NVD
- FIRST EPSS
- GHSA-3q79-wmhj-39pr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences