Nomad Vulnerable To Violation Of Mandatory Sentinel Policies in Nomad Job Submissions via Policy Override
Priority LOW 33CWE-266Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-266.
Summary
Nomad Enterprise (“Nomad”) jobs using the policy override option are bypassing the mandatory sentinel policies. This vulnerability, identified as CVE-2025-3744, is fixed in Nomad Enterprise 1.10.1, 1.9.9, and 1.8.13.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00295 22nd percentileScored 2026-11-07
Fix Fixed Nomad Enterprise (HashiCorp): 1.10.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HashiCorp | Nomad Enterprise | before 1.10.1 | 1.10.1 | Patch available | CNA |
- Nomad Enterprise VendorHashiCorp Affected before 1.10.1 Fixed in 1.10.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* | before 1.8.13; 1.9.0 to before 1.9.9 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:1.10.0:-:*:*:enterprise:*:*:* | 1.10.0 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:1.10.0:beta1:*:*:enterprise:*:*:* | 1.10.0 beta1 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:1.10.0:rc1:*:*:enterprise:*:*:* | 1.10.0 rc1 | Vulnerable | HashiCorp |
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* Versions before 1.8.13; 1.9.0 to before 1.9.9 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:1.10.0:-:*:*:enterprise:*:*:* Versions 1.10.0 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:1.10.0:beta1:*:*:enterprise:*:*:* Versions 1.10.0 beta1 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:1.10.0:rc1:*:*:enterprise:*:*:* Versions 1.10.0 rc1 Vulnerable ·HashiCorp
Remediation
- Fix · CNA Nomad Enterprise (HashiCorp) Fixed in 1.10.1
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3744
- 2026-10-03 Alias added: GHSA-9vr5-w737-m66g
References
More HashiCorp Nomad vulnerabilities
- TI-2019-09419 HashiCorp Nomad 0.9.0 through 0.9.1 has Incorrect Access Control via the exec driver. CVSS 3.0CRITICAL 9.8
- TI-2022-12559 HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter… CVSS 3.1CRITICAL 9.8
- TI-2023-01674 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation CVSS 3.1CRITICAL 10.0
- TI-2020-06436 HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region… CVSS 3.1CRITICAL 9.8
- TI-2020-16532 HashiCorp Nomad and Nomad Enterprise version 0.9.0 up to 0.12.5 client file sandbox… CVSS 3.1CRITICAL 9.1
- TI-2021-19357 HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task… CVSS 3.1HIGH 8.8
Sources
- CVE-2025-3744 · CVE Program
- CVE-2025-3744 · NVD
- FIRST EPSS
- GHSA-9vr5-w737-m66g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences