Read the docs
TI-2025-03360 Aliases CVE-2025-3810GHSA-r7x3-qhq3-x8hr

WPBookit <= 1.0.2 - Insecure Direct Object Reference to Unauthenticated Privilege Escalation via Account Takeover

Priority MEDIUM 50CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-639.

Summary

The WPBookit plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 1.0.2. This is due to the plugin not properly validating a user's identity prior to updating their details like password and email through the edit_profile_data() function. This makes it possible for unauthenticated attackers to change arbitrary user's email addresses and passwords, including administrators, and leverage that to gain access to their account.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00754 55th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
iqonicdesignWPBookitup to 1.0.2—No fix listedCNA
  • WPBookit Vendoriqonicdesign Affected up to 1.0.2 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:iqonic:wpbookit:*:*:*:*:free:wordpress:*:*before 1.0.3Vulnerableiqonicdesign
  • cpe:2.3:a:iqonic:wpbookit:*:*:*:*:free:wordpress:*:* Versions before 1.0.3 Vulnerable ·iqonicdesign

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-3810
  2. 2026-10-03 Alias added: GHSA-r7x3-qhq3-x8hr

References

  • TI-2024-36369 WordPress WPBookit plugin <= 1.6.0 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-05470 WPBookit <= 1.0.4 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
  • TI-2025-00290 WPBookit <= 1.6.9 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
  • TI-2025-03361 WPBookit <= 1.0.2 - Insecure Direct Object Reference to Unauthenticated Privilege Escalation via Email Update CVSS 3.1CRITICAL 9.8
  • TI-2024-09472 WPBookit <= 1.6.4 - Unauthenticated Arbitrary User Password Change CVSS 3.1CRITICAL 9.8
  • TI-2025-05469 WPBookit <= 1.0.4 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1HIGH 8.8
See all 8 →

Sources