Yggdrasil: local privilege escalation in yggdrasil
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
A flaw was found in Yggdrasil, which acts as a system broker, allowing the processes to communicate to other children's "worker" processes through the DBus component. Yggdrasil creates a DBus method to dispatch messages to workers. However, it misses authentication and authorization checks, allowing every system user to call it. One available Yggdrasil worker acts as a package manager with capabilities to create and enable new repositories and install or remove packages. This flaw allows an attacker with access to the system to leverage the lack of authentication on the dispatch message to force the Yggdrasil worker to install arbitrary RPM packages. This issue results in local privilege escalation, enabling the attacker to access and modify sensitive system data.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | yggdrasil | before 0.4.7 | 0.4.7 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 10 | — | 0.4.5-3.el10_0 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 10 | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 8 | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 9 | — | — | Not affected | CNA |
| Red Hat | Red Hat Satellite 6 | — | — | Not affected | CNA |
| — | github.com/redhatinsights/yggdrasil (Go) | up to 0.4.6 | — | No fix listed | GHSA-rpg2-jvhp-h354 |
- yggdrasil Vendor— Affected before 0.4.7 Fixed in 0.4.7 Patch available CNA
- Red Hat Enterprise Linux 10 VendorRed Hat Affected — Fixed in 0.4.5-3.el10_0 Patch available CNA
- Red Hat Enterprise Linux 10 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Satellite 6 VendorRed Hat Affected — Fixed in — Not affected CNA
- github.com/redhatinsights/yggdrasil (Go) Vendor— Affected up to 0.4.6 Fixed in — No fix listed GHSA-rpg2-jvhp-h354
Remediation
- Fix · CNA yggdrasil Fixed in 0.4.7
Red Hat 1 advisory
- RHSA-2025:7592 Released 2025-05-14 · Red Hat rating Importantyggdrasil security update
- Red Hat Enterprise Linux AppStream (v. 10) yggdrasil-0.4.5-3.el10_0
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) yggdrasil-devel-0.4.5-3.el10_0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2025:7592 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2025:7592 |
Not affected: 4 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2025-3931
- 2026-10-03 Alias added: GHSA-rpg2-jvhp-h354
References
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-3931 · CVE Program
- CVE-2025-3931 · NVD
- FIRST EPSS
- GHSA-rpg2-jvhp-h354 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-3931 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences