Incorrect authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
The MultiVendorX – WooCommerce Multivendor Marketplace Solutions plugin for WordPress is vulnerable to unauthorized loss of data due to a misconfigured capability check on the 'delete_fpm_product' function in all versions up to, and including, 4.2.22. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary posts, pages, attachments, and products. The vulnerability was partially patched in version 4.2.22.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MultiVendorX | MultiVendorX – WooCommerce Multivendor Marketplace Solutions | up to 4.2.22 | — | No fix listed | CNA |
- MultiVendorX – WooCommerce Multivendor Marketplace Solutions VendorMultiVendorX Affected up to 4.2.22 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:multivendorx:multivendorx:*:*:*:*:*:wordpress:*:* | before 4.2.23 | Vulnerable | MultiVendorX |
- cpe:2.3:a:multivendorx:multivendorx:*:*:*:*:*:wordpress:*:* Versions before 4.2.23 Vulnerable ·MultiVendorX
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4101
- 2026-10-03 Alias added: GHSA-8743-487v-2xqh
References
More Multivendorx vulnerabilities
- TI-2025-00410 Path traversal in MultiVendorX – WooCommerce Multivendor Marketplace Solutions CVSS 3.1CRITICAL 9.8
- TI-2024-07685 Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions CVSS 3.1CRITICAL 9.8
- TI-2025-30587 WordPress MultiVendorX plugin <= 4.2.22 - Sensitive Data Exposure Vulnerability CVSS 3.1HIGH 7.5
- TI-2024-20680 WordPress MultiVendorX Marketplace <= 4.1.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2025-02437 Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions CVSS 3.1MEDIUM 6.5
- TI-2025-30589 WordPress MultiVendorX plugin <= 4.2.22 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-4101 · CVE Program
- CVE-2025-4101 · NVD
- FIRST EPSS
- GHSA-8743-487v-2xqh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences