Beaver Builder Plugin (Starter Version) <= 2.9.1 - Authenticated (Administrator+) Arbitrary File Upload
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_enabled_icons' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 2.9.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| beaverbuilder | Beaver Builder Plugin (Starter Version) | up to 2.9.1 | — | No fix listed | CNA |
- Beaver Builder Plugin (Starter Version) Vendorbeaverbuilder Affected up to 2.9.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fastlinemedia:beaver_builder:*:*:*:*:lite:wordpress:*:* | before 2.9.1.1 | Vulnerable | beaverbuilder |
- cpe:2.3:a:fastlinemedia:beaver_builder:*:*:*:*:lite:wordpress:*:* Versions before 2.9.1.1 Vulnerable ·beaverbuilder
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4102
- 2026-10-03 Alias added: GHSA-c4hq-vq7x-9xjf
References
More beaverbuilder Beaver Builder vulnerabilities
- TI-2024-29515 WordPress Beaver Builder plugin <= 2.8.3.2 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2022-16754 WordPress Beaver Builder plugin <= 2.5.4.3 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-35995 WordPress Beaver Builder plugin <= 2.8.4.3 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-25004 WordPress Beaver Builder plugin <= 2.8.2.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-20151 WordPress Beaver Builder plugin <= 2.7.4.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-07317 Beaver Builder (Lite Version) <= 2.8.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via type Parameter CVSS 3.1MEDIUM 6.4
Sources
- CVE-2025-4102 · CVE Program
- CVE-2025-4102 · NVD
- FIRST EPSS
- GHSA-c4hq-vq7x-9xjf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences