PostgreSQL GB18030 encoding validation can read one byte past end of allocation for text that fails validation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 fixed, 5 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-126 and the CVSS impact.
Summary
Buffer over-read in PostgreSQL GB18030 encoding validation allows a database input provider to achieve temporary denial of service on platforms where a 1-byte over-read can elicit process termination. This affects the database server and also libpq. Versions before PostgreSQL 17.5, 16.9, 15.13, 14.18, and 13.21 are affected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | PostgreSQL | 17 to before 17.5; 16 to before 16.9; 15 to before 15.13; 14 to before 14.18; before 13.21 | 17.5, 16.9, 15.13, 14.18, 13.21 | Patch available | CNA |
- PostgreSQL Vendor— Affected 17 to before 17.5; 16 to before 16.9; 15 to before 15.13; 14 to before 14.18; before 13.21 Fixed in 17.5, 16.9, 15.13, 14.18, 13.21 Patch available CNA
Remediation
- Fix · CNA PostgreSQL Fixed in 17.5, 16.9, 15.13, 14.18, 13.21
Red Hat 6 advisories
- RHSA-2025:15022 Released 2025-09-02 · Red Hat rating Importantpostgresql:15 security update
- Red Hat Enterprise Linux AppStream (v. 8) pg_repack-1.4.8-1.module+el8.9.0+19797+c4ce5969.aarch64::postgresql:15, pg_repack-1.4.8-1.module+el8.9.0+19797+c4ce5969.ppc64le::postgresql:15, pg_repack-1.4.8-1.module+el8.9.0+19797+c4ce5969.s390x::postgresql:15 +47
- RHSA-2025:15021 Released 2025-09-02 · Red Hat rating Importantpostgresql:13 security update
- Red Hat Enterprise Linux AppStream (v. 8) pg_repack-1.4.6-3.module+el8.9.0+20664+9c30cf7f.aarch64::postgresql:13, pg_repack-1.4.6-3.module+el8.9.0+20664+9c30cf7f.ppc64le::postgresql:13, pg_repack-1.4.6-3.module+el8.9.0+20664+9c30cf7f.s390x::postgresql:13 +47
- RHSA-2025:14899 Released 2025-08-28 · Red Hat rating Importantpostgresql:16 security update
- Red Hat Enterprise Linux AppStream (v. 8) pg_repack-1.5.1-1.module+el8.10.0+22551+c0330dc9.aarch64::postgresql:16, pg_repack-1.5.1-1.module+el8.10.0+22551+c0330dc9.ppc64le::postgresql:16, pg_repack-1.5.1-1.module+el8.10.0+22551+c0330dc9.s390x::postgresql:16 +47
Show 3 more Red Hat advisories
- RHSA-2025:14862 Released 2025-08-28 · Red Hat rating Importantpostgresql:15 security update
- Red Hat Enterprise Linux AppStream (v. 9) pg_repack-1.4.8-2.module+el9.5.0+22224+f5585c78.aarch64::postgresql:15, pg_repack-1.4.8-2.module+el9.5.0+22224+f5585c78.ppc64le::postgresql:15, pg_repack-1.4.8-2.module+el9.5.0+22224+f5585c78.s390x::postgresql:15 +47
- RHSA-2025:14827 Released 2025-08-28 · Red Hat rating Importantpostgresql:16 security update
- Red Hat Enterprise Linux AppStream (v. 9) pg_repack-1.5.1-1.module+el9.6.0+22880+6b241eec.aarch64::postgresql:16, pg_repack-1.5.1-1.module+el9.6.0+22880+6b241eec.ppc64le::postgresql:16, pg_repack-1.5.1-1.module+el9.6.0+22880+6b241eec.s390x::postgresql:16 +47
- RHSA-2025:14826 Released 2025-08-28 · Red Hat rating Importantpostgresql16 security update
- Red Hat Enterprise Linux AppStream (v. 10) postgresql-16.10-1.el10_0, postgresql-contrib-16.10-1.el10_0, postgresql-docs-16.10-1.el10_0 +12
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) postgresql-test-rpm-macros-16.10-1.el10_0
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2025:14826 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2025:14899, RHSA-2025:15021, RHSA-2025:15022 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:14827, RHSA-2025:14862 |
Not affected: 2 products
- Red Hat Enterprise Linux AppStream (v. 10)
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10)
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4207
- 2026-10-03 Alias added: GHSA-6x46-2273-xjjf
References
Sources
- CVE-2025-4207 · CVE Program
- CVE-2025-4207 · NVD
- FIRST EPSS
- GHSA-6x46-2273-xjjf · GitHub Advisory Database · CC BY 4.0
- CVE-2025-4207 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences