PAN-OS: Authenticated Admin Command Injection Vulnerability in the Management Web Interface
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-77.
Summary
A command injection vulnerability in Palo Alto Networks PAN-OS® enables an authenticated administrative user to perform actions as the root user. The attacker must have network access to the management web interface and successfully authenticate to exploit this issue. Cloud NGFW and Prisma Access are not impacted by this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | Cloud NGFW | — | All | Patch available | CNA |
| Palo Alto Networks | PAN-OS | 11.0.0 to before 11.0.3; 10.2.0 to before 10.2.8; 10.1.0 | 11.2.0, 11.1.0, 11.0.3, 10.2.8 | Patch available | CNA |
| Palo Alto Networks | Prisma Access | — | All | Patch available | CNA |
- Cloud NGFW VendorPalo Alto Networks Affected — Fixed in All Patch available CNA
- PAN-OS VendorPalo Alto Networks Affected 11.0.0 to before 11.0.3; 10.2.0 to before 10.2.8; 10.1.0 Fixed in 11.2.0, 11.1.0, 11.0.3, 10.2.8 Patch available CNA
- Prisma Access VendorPalo Alto Networks Affected — Fixed in All Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* | 10.2.0 to before 10.2.8; 11.0.0 to before 11.0.3 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
- cpe:2.3:o:paloaltonetworks:pan-os:*:*:*:*:*:*:*:* Versions 10.2.0 to before 10.2.8; 11.0.0 to before 11.0.3 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
Remediation
- Fix · CNA Cloud NGFW (Palo Alto Networks) Fixed in All
- Fix · CNA PAN-OS (Palo Alto Networks) Fixed in 11.2.0, 11.1.0, 11.0.3, 10.2.8
- Fix · CNA Prisma Access (Palo Alto Networks) Fixed in All
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Palo Alto Networks Cloud NGFW 6.3.3
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2025-03763 PAN-OS: Authenticated Admin Command Injection Vulnerability Through CLIPriority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4231
- 2026-10-03 Alias added: GHSA-vm6c-rqg9-5qqr
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2025-4231 · CVE Program
- CVE-2025-4231 · NVD
- FIRST EPSS
- GHSA-vm6c-rqg9-5qqr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences