Authorization bypass in Syntactics, Inc. eaSYNC Booking – Hotels, Restaurants & Car…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-639.
Summary
The Free Booking Plugin for Hotels, Restaurants and Car Rentals – eaSYNC Booking plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.3.21 via the 'view_request_details' due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to view the details of any booking request. The vulnerability was partially patched in versions 1.3.18 and 1.3.21.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Syntactics, Inc. | eaSYNC Booking – Hotels, Restaurants & Car Rentals | up to 1.3.21 | — | No fix listed | CNA |
- eaSYNC Booking – Hotels, Restaurants & Car Rentals VendorSyntactics, Inc. Affected up to 1.3.21 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:syntacticsinc:easync:*:*:*:*:*:wordpress:*:* | before 1.3.22 | Vulnerable | Syntacticsinc |
- cpe:2.3:a:syntacticsinc:easync:*:*:*:*:*:wordpress:*:* Versions before 1.3.22 Vulnerable ·Syntacticsinc
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4691
- 2026-10-03 Alias added: GHSA-r4jv-p8qq-69jq
References
Patch 3
More Syntactics, Inc. vulnerabilities
- TI-2022-04562 Freemius SDK <= 2.4.2 - Missing Authorization Checks CVSS 3.1MEDIUM 6.3
- TI-2025-23316 WordPress eaSYNC plugin <= 1.3.19 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2025-4691 · CVE Program
- CVE-2025-4691 · NVD
- FIRST EPSS
- GHSA-r4jv-p8qq-69jq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences