Nomad Vulnerable To Incorrect ACL Policy Lookup Attached To A Job
Priority LOW 38CWE-266Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-266.
Summary
Nomad Community and Nomad Enterprise (“Nomad”) prefix-based ACL policy lookup can lead to incorrect rule application and shadowing. This vulnerability, identified as CVE-2025-4922, is fixed in Nomad Community Edition 1.10.2 and Nomad Enterprise 1.10.2, 1.9.10, and 1.8.14.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00512 43rd percentileScored 2026-11-07
Fix Fixed Nomad (HashiCorp): 1.10.2Nomad Enterprise (HashiCorp): 1.10.2+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HashiCorp | Nomad | 1.4.0 to before 1.10.2 | 1.10.2 | Patch available | CNA |
| HashiCorp | Nomad Enterprise | 1.4.0 to before 1.10.2 | 1.10.2 | Patch available | CNA |
| — | github.com/hashicorp/nomad (Go) | before 1.10.2 | 1.10.2 | Patch available | GHSA-rx97-6c62-55mf |
- Nomad VendorHashiCorp Affected 1.4.0 to before 1.10.2 Fixed in 1.10.2 Patch available CNA
- Nomad Enterprise VendorHashiCorp Affected 1.4.0 to before 1.10.2 Fixed in 1.10.2 Patch available CNA
- github.com/hashicorp/nomad (Go) Vendor— Affected before 1.10.2 Fixed in 1.10.2 Patch available GHSA-rx97-6c62-55mf
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* | 1.4.0 to before 1.8.14 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* | 1.4.0 to before 1.10.2 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* | 1.9.0 to before 1.9.10; 1.10.0 to before 1.10.2 | Vulnerable | HashiCorp |
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* Versions 1.4.0 to before 1.8.14 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* Versions 1.4.0 to before 1.10.2 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* Versions 1.9.0 to before 1.9.10; 1.10.0 to before 1.10.2 Vulnerable ·HashiCorp
Remediation
- Fix · CNA Nomad (HashiCorp) Fixed in 1.10.2
- Fix · CNA Nomad Enterprise (HashiCorp) Fixed in 1.10.2
- Fix · GHSA-rx97-6c62-55mf github.com/hashicorp/nomad (Go) Fixed in 1.10.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4922
- 2026-10-03 Alias added: GHSA-rx97-6c62-55mf
References
More HashiCorp Nomad vulnerabilities
- TI-2019-09419 HashiCorp Nomad 0.9.0 through 0.9.1 has Incorrect Access Control via the exec driver. CVSS 3.0CRITICAL 9.8
- TI-2022-12559 HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter… CVSS 3.1CRITICAL 9.8
- TI-2023-01674 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation CVSS 3.1CRITICAL 10.0
- TI-2020-06436 HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region… CVSS 3.1CRITICAL 9.8
- TI-2020-16532 HashiCorp Nomad and Nomad Enterprise version 0.9.0 up to 0.12.5 client file sandbox… CVSS 3.1CRITICAL 9.1
- TI-2021-19357 HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task… CVSS 3.1HIGH 8.8
Sources
- CVE-2025-4922 · CVE Program
- CVE-2025-4922 · NVD
- FIRST EPSS
- GHSA-rx97-6c62-55mf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences