WP Import Export Lite <= 3.9.29 - Authenticated (Subscriber+) Arbitrary File Upload
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.
Summary
The WP Import Export Lite plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'wpie_parse_upload_data' function in all versions up to, and including, 3.9.29. This makes it possible for authenticated attackers, with Subscriber-level access and above, and permissions granted by an Administrator, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 3.9.29.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vjinfotech | WP Import Export Lite | up to 3.9.29 | — | No fix listed | CNA |
- WP Import Export Lite Vendorvjinfotech Affected up to 3.9.29 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vjinfotech:wp_import_export_lite:*:*:*:*:*:wordpress:*:* | before 3.9.30 | Vulnerable | vjinfotech |
- cpe:2.3:a:vjinfotech:wp_import_export_lite:*:*:*:*:*:wordpress:*:* Versions before 3.9.30 Vulnerable ·vjinfotech
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5061
- 2026-10-03 Alias added: GHSA-7c74-cfcr-227g
References
Patch 2
More vjinfotech Wp Import Export Lite vulnerabilities
- TI-2022-00172 WP Import Export (Lite) <= 3.9.15 Unauthenticated Sensitive Data Disclosure CVSS 3.1HIGH 7.5
- TI-2025-05615 WP Import Export Lite <= 3.9.28 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2024-20684 WordPress WP Import Export Lite & WP Import Export plugin <= 3.9.26 - PHP Object Injection vulnerability CVSS 3.1HIGH 7.2
- TI-2025-02479 WP Import Export Lite <= 3.9.27 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2025-5061 · CVE Program
- CVE-2025-5061 · NVD
- FIRST EPSS
- GHSA-7c74-cfcr-227g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences