Custom Post Carousels with Owl < 1.4.12 - Contributor+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Custom Post Carousels with Owl WordPress plugin before 1.4.12 uses the featherlight library and makes use of the data-featherlight attribute without sanitizing before using it.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00247 16th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Custom Post Carousels with Owl (Unknown): 1.4.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Custom Post Carousels with Owl | before 1.4.12 | 1.4.12 | Patch available | CNA |
- Custom Post Carousels with Owl VendorUnknown Affected before 1.4.12 Fixed in 1.4.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:howardehrenberg:custom_post_carousels_with_owl:*:*:*:*:*:wordpress:*:* | before 1.4.12 | Vulnerable | Howard Ehrenberg |
- cpe:2.3:a:howardehrenberg:custom_post_carousels_with_owl:*:*:*:*:*:wordpress:*:* Versions before 1.4.12 Vulnerable ·Howard Ehrenberg
Remediation
- Fix · CNA Custom Post Carousels with Owl (Unknown) Fixed in 1.4.12
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5125
- 2026-10-03 Alias added: GHSA-f6jx-7qrr-8hv7
References
More Howard Ehrenberg Custom Post Carousels With Owl vulnerabilities
- TI-2023-28145 WordPress Custom Post Carousels with Owl Plugin <= 1.4.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-5125 · CVE Program
- CVE-2025-5125 · NVD
- FIRST EPSS
- GHSA-f6jx-7qrr-8hv7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences