Teledyne FLIR AX8 prod.php cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79 and CWE-94.
Summary
A vulnerability was determined in Teledyne FLIR AX8 up to 1.46.16. This issue affects some unknown processing of the file /prod.php. Executing manipulation of the argument cmd can lead to cross site scripting. The attack may be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 1.49.16 is capable of addressing this issue. It is recommended to upgrade the affected component. The vendor points out: "FLIR AX8 internal web site has been refactored to be able to handle the reported vulnerabilities."
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Teledyne FLIR | AX8 | 1.46.0; 1.46.1; 1.46.2; 1.46.3; 1.46.4; 1.46.5; 1.46.6; 1.46.7; 1.46.8; 1.46.9; 1.46.10; 1.46.11; 1.46.12; 1.46.13; 1.46.14; 1.46.15; 1.46.16 | 1.49.16 | Patch available | CNA |
- AX8 VendorTeledyne FLIR Affected 1.46.0; 1.46.1; 1.46.2; 1.46.3; 1.46.4; 1.46.5; 1.46.6; 1.46.7; 1.46.8; 1.46.9; 1.46.10; 1.46.11; 1.46.12; 1.46.13; 1.46.14; 1.46.15; 1.46.16 Fixed in 1.49.16 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:flir:flir_ax8_firmware:*:*:*:*:*:*:*:* | 1.46.0 – 1.46.16 | Vulnerable | Teledyne FLIR |
| cpe:2.3:h:flir:flir_ax8:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Teledyne FLIR |
- cpe:2.3:o:flir:flir_ax8_firmware:*:*:*:*:*:*:*:* Versions 1.46.0 – 1.46.16 Vulnerable ·Teledyne FLIR
- cpe:2.3:h:flir:flir_ax8:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Teledyne FLIR
Remediation
- Fix · CNA AX8 (Teledyne FLIR) Fixed in 1.49.16
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5127
- 2026-10-03 Alias added: GHSA-chj7-qrp5-w4fh
More Teledyne FLIR Flir Ax8 Firmware vulnerabilities
- TI-2022-17254 All FLIR AX8 thermal sensor cameras version up to and including 1.46.16 are vulnerable to… CVSS 3.1CRITICAL 9.8
- TI-2018-15364 FLIR AX8 Thermal Camera 1.32.16 Hard-Coded Credentials Authentication Bypass CVSS 4.0CRITICAL 9.3
- TI-2018-15365 FLIR AX8 Thermal Camera 1.32.16 Unauthenticated RTSP Stream Disclosure CVSS 4.0HIGH 8.7
- TI-2025-04595 Teledyne FLIR AX8 settingsregional.php setDataTime command injection CVSS 4.0HIGH 8.7
- TI-2022-03997 Teledyne FLIR AX8 Web Service palette.php command injection CVSS 4.0MEDIUM 6.9
- TI-2023-27944 Command injection vulnerability in /usr/www/res.php in FLIR AX8 up to 1.46.16 allows… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-5127 · CVE Program
- CVE-2025-5127 · NVD
- FIRST EPSS
- GHSA-chj7-qrp5-w4fh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences