erdogant pypickle pypickle.py save improper authorization
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation, Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-266 and CWE-285.
Summary
A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| erdogant | pypickle | 1.1.0; 1.1.1; 1.1.2; 1.1.3; 1.1.4; 1.1.5 | — | No fix listed | CNA |
| — | pypickle (PyPI) | before 2.0.0 | 2.0.0 | Patch available | GHSA-qpxx-2cwh-r5vh |
- pypickle Vendorerdogant Affected 1.1.0; 1.1.1; 1.1.2; 1.1.3; 1.1.4; 1.1.5 Fixed in — No fix listed CNA
- pypickle (PyPI) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-qpxx-2cwh-r5vh
Remediation
- Fix · GHSA-qpxx-2cwh-r5vh pypickle (PyPI) Fixed in 2.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5175
- 2026-10-03 Alias added: GHSA-qpxx-2cwh-r5vh
References
Exploit 3
Patch 2
More erdogant Pypickle vulnerabilities
- TI-2025-04643 erdogant pypickle pypickle.py load deserialization CVSS 4.0MEDIUM 4.8
Sources
- CVE-2025-5175 · CVE Program
- CVE-2025-5175 · NVD
- FIRST EPSS
- GHSA-qpxx-2cwh-r5vh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences