Read the docs
TI-2025-04738 Aliases CVE-2025-5275GHSA-jj56-99pp-w4hp

Charitable <= 1.8.6.1 - Authenticated (Administrator+) Stored Cross-Site Scripting via Plugin's Privacy Settings

Priority LOW 20CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations & More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the privacy settings fields in all versions up to, and including, 1.8.6.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled. This issue was partially fixed in version 1.8.6.1 and fully fixed in version 1.8.6.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00206 10th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
smubCharitable – Donation Plugin for WordPress – Fundraising with Recurring Donations & Moreup to 1.8.6.1—No fix listedCNA
  • Charitable – Donation Plugin for WordPress – Fundraising with Recurring Donations & More Vendorsmub Affected up to 1.8.6.1 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpbeginner:charitable:*:*:*:*:-:wordpress:*:*before 1.8.6.2VulnerableWpbeginner
  • cpe:2.3:a:wpbeginner:charitable:*:*:*:*:-:wordpress:*:* Versions before 1.8.6.2 Vulnerable ·Wpbeginner

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-5275
  2. 2026-10-03 Alias added: GHSA-jj56-99pp-w4hp

References

  • TI-2026-07755 WPCode <= 2.3.5 - Authenticated (Author+) Remote Code Execution via CPT Capability Bypass via XML-RPC wp.newPost CVSS 3.1HIGH 8.8
  • TI-2026-83530 Remote code execution in NextGEN Gallery plugin for WordPress CVSS 3.1HIGH 8.8
  • TI-2026-78567 PHP object injection in Duplicator and Duplicator Pro plugins CVSS 3.1HIGH 8.8
  • TI-2026-01649 ExactMetrics 8.6.0 - 9.0.2 - Authenticated (Custom) Insecure Direct Object Reference to Arbitrary Plugin Installation CVSS 3.1HIGH 8.8
  • TI-2026-01160 Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery <= 4.0.4 - Authenticated (Author+) Local File Inclusion CVSS 3.1HIGH 8.8
  • TI-2025-12465 Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery <= 3.59.12 - Authenticated… CVSS 3.1HIGH 8.8
See all 67 →

Sources