Denial of Service (DOS) in JSONReader in run-llama/llama_index
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-674.
Summary
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| run-llama | run-llama/llama_index | before 0.12.38 | 0.12.38 | Patch available | CNA |
| — | llama-index-core (PyPI) | before 0.12.38 | 0.12.38 | Patch available | GHSA-7753-xrfw-ch36 |
- run-llama/llama_index Vendorrun-llama Affected before 0.12.38 Fixed in 0.12.38 Patch available CNA
- llama-index-core (PyPI) Vendor— Affected before 0.12.38 Fixed in 0.12.38 Patch available GHSA-7753-xrfw-ch36
Remediation
- Fix · CNA run-llama/llama_index (run-llama) Fixed in 0.12.38
- Fix · GHSA-7753-xrfw-ch36 llama-index-core (PyPI) Fixed in 0.12.38 Advisory →
Red Hat 1 advisory
- RHSA-2025:16514 Released 2025-09-23 · Red Hat rating ImportantRed Hat Ansible Automation Platform 2.5 Container Release Update
- Red Hat Ansible Automation Platform 2.5 for RHEL 8 ansible-automation-platform-25/lightspeed-chatbot-rhel8, ansible-automation-platform-25/lightspeed-rhel8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | Fixed | RHSA-2025:16514 |
Not affected: 3 products
- Red Hat Ansible Automation Platform 2
- Red Hat Ansible Automation Platform 2.5 for RHEL 8
- Red Hat Ansible Automation Platform 2.5 for RHEL 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5302
- 2026-10-03 Alias added: GHSA-7753-xrfw-ch36
References
More run-llama vulnerabilities
- TI-2025-01545 SQL Injection in run-llama/llama_index CVSS 3.0CRITICAL 9.8
- TI-2025-01507 SQL Injection in run-llama/llama_index CVSS 3.0CRITICAL 9.8
- TI-2024-11960 SQL Injection to RCE in run-llama/llama_index CVSS 3.1CRITICAL 9.8
- TI-2024-11094 SQL Injection in run-llama/llama_index CVSS 3.0CRITICAL 9.8
- TI-2024-03068 Command Injection in run-llama/llama_index CVSS 3.0CRITICAL 9.8
- TI-2024-02902 Prompt Injection leading to Arbitrary Code Execution in run-llama/llama_index CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-5302 · CVE Program
- CVE-2025-5302 · NVD
- FIRST EPSS
- GHSA-7753-xrfw-ch36 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-5302 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences