Denial of Service via Uncontrolled Recursive JSON Parsing in JSONReader in run-llama/llama_index
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-674.
Summary
The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| run-llama | run-llama/llama_index | before 0.12.38 | 0.12.38 | Patch available | CNA |
| — | llama-index-core (PyPI) | before 0.12.38 | 0.12.38 | Patch available | GHSA-3wxx-q3gv-pvvv |
- run-llama/llama_index Vendorrun-llama Affected before 0.12.38 Fixed in 0.12.38 Patch available CNA
- llama-index-core (PyPI) Vendor— Affected before 0.12.38 Fixed in 0.12.38 Patch available GHSA-3wxx-q3gv-pvvv
Remediation
- Fix · CNA run-llama/llama_index (run-llama) Fixed in 0.12.38
- Fix · GHSA-3wxx-q3gv-pvvv llama-index-core (PyPI) Fixed in 0.12.38 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Lightspeed | Affected | No fix yet: Fix deferred |
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5472
- 2026-10-03 Alias added: GHSA-3wxx-q3gv-pvvv
References
More run-llama Llamaindex vulnerabilities
- TI-2025-01545 SQL Injection in run-llama/llama_index CVSS 3.0CRITICAL 9.8
- TI-2025-01507 SQL Injection in run-llama/llama_index CVSS 3.0CRITICAL 9.8
- TI-2024-11960 SQL Injection to RCE in run-llama/llama_index CVSS 3.1CRITICAL 9.8
- TI-2024-11094 SQL Injection in run-llama/llama_index CVSS 3.0CRITICAL 9.8
- TI-2024-03068 Command Injection in run-llama/llama_index CVSS 3.0CRITICAL 9.8
- TI-2024-15754 LlamaIndex (aka llama_index) through 0.9.34 allows SQL injection via the Text-to-SQL… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-5472 · CVE Program
- CVE-2025-5472 · NVD
- FIRST EPSS
- GHSA-3wxx-q3gv-pvvv · GitHub Advisory Database · CC BY 4.0
- CVE-2025-5472 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences