Teledyne FLIR AX8 Backend subscriptions.php subscribe_to_alarm command injection
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-77.
Summary
A vulnerability has been found in Teledyne FLIR AX8 up to 1.46.16. This impacts the function subscribe_to_spot/subscribe_to_delta/subscribe_to_alarm of the file /usr/www/application/models/subscriptions.php of the component Backend. Such manipulation leads to command injection. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.49.16 will fix this issue. It is suggested to upgrade the affected component. The vendor points out: "FLIR AX8 internal web site has been refactored to be able to handle the reported vulnerabilities."
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Teledyne FLIR | AX8 | 1.46.0; 1.46.1; 1.46.2; 1.46.3; 1.46.4; 1.46.5; 1.46.6; 1.46.7; 1.46.8; 1.46.9; 1.46.10; 1.46.11; 1.46.12; 1.46.13; 1.46.14; 1.46.15; 1.46.16 | 1.49.16 | Patch available | CNA |
- AX8 VendorTeledyne FLIR Affected 1.46.0; 1.46.1; 1.46.2; 1.46.3; 1.46.4; 1.46.5; 1.46.6; 1.46.7; 1.46.8; 1.46.9; 1.46.10; 1.46.11; 1.46.12; 1.46.13; 1.46.14; 1.46.15; 1.46.16 Fixed in 1.49.16 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:flir:flir_ax8_firmware:*:*:*:*:*:*:*:* | 1.46.0 – 1.46.16 | Vulnerable | Teledyne FLIR |
| cpe:2.3:h:flir:flir_ax8:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Teledyne FLIR |
- cpe:2.3:o:flir:flir_ax8_firmware:*:*:*:*:*:*:*:* Versions 1.46.0 – 1.46.16 Vulnerable ·Teledyne FLIR
- cpe:2.3:h:flir:flir_ax8:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Teledyne FLIR
Remediation
- Fix · CNA AX8 (Teledyne FLIR) Fixed in 1.49.16
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5695
- 2026-10-03 Alias added: GHSA-wxmp-jjxp-g7gp
References
Exploit 2
More Teledyne FLIR Flir Ax8 Firmware vulnerabilities
- TI-2022-17254 All FLIR AX8 thermal sensor cameras version up to and including 1.46.16 are vulnerable to… CVSS 3.1CRITICAL 9.8
- TI-2018-15364 FLIR AX8 Thermal Camera 1.32.16 Hard-Coded Credentials Authentication Bypass CVSS 4.0CRITICAL 9.3
- TI-2018-15365 FLIR AX8 Thermal Camera 1.32.16 Unauthenticated RTSP Stream Disclosure CVSS 4.0HIGH 8.7
- TI-2025-04595 Teledyne FLIR AX8 settingsregional.php setDataTime command injection CVSS 4.0HIGH 8.7
- TI-2022-03997 Teledyne FLIR AX8 Web Service palette.php command injection CVSS 4.0MEDIUM 6.9
- TI-2023-27944 Command injection vulnerability in /usr/www/res.php in FLIR AX8 up to 1.46.16 allows… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-5695 · CVE Program
- CVE-2025-5695 · NVD
- FIRST EPSS
- GHSA-wxmp-jjxp-g7gp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences