Unitech pm2 Config.js redos
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-1333.
Summary
A vulnerability classified as problematic was found in Unitech pm2 up to 6.0.6. This vulnerability affects unknown code of the file /lib/tools/Config.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unitech | pm2 | 6.0.0; 6.0.1; 6.0.2; 6.0.3; 6.0.4; 6.0.5; 6.0.6 | — | No fix listed | CNA |
| — | pm2 (npm) | before 7.0.0 | 7.0.0 | Patch available | GHSA-x5gf-qvw8-r2rm |
- pm2 VendorUnitech Affected 6.0.0; 6.0.1; 6.0.2; 6.0.3; 6.0.4; 6.0.5; 6.0.6 Fixed in — No fix listed CNA
- pm2 (npm) Vendor— Affected before 7.0.0 Fixed in 7.0.0 Patch available GHSA-x5gf-qvw8-r2rm
Remediation
- Fix · GHSA-x5gf-qvw8-r2rm pm2 (npm) Fixed in 7.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5891
- 2026-10-03 Alias added: GHSA-x5gf-qvw8-r2rm
- 2026-10-13 EPSS moved to the 50th–90th percentile
References
Exploit 2
Other 5
- https://github.com/Unitech/pm2/issues/6075
- https://github.com/Unitech/pm2/commit/8b9354800a1d157cb9503a3ec414ef1e4700dc1c
- https://github.com/Unitech/pm2
- https://github.com/Unitech/pm2/blob/ba62cae9b9b7116ee758b70f538919a52515fa26/CHANGELOG.md?plain=1#L36
- https://github.com/Unitech/pm2/releases/tag/v7.0.0
Sources
- CVE-2025-5891 · CVE Program
- CVE-2025-5891 · NVD
- FIRST EPSS
- GHSA-x5gf-qvw8-r2rm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences