Read the docs
TI-2025-05360 Aliases CVE-2025-5934GHSA-942c-3x7c-8jqx

Netgear EX3700 mtd sub_41619C stack-based overflow

Priority HIGH 73CWE-119Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-119 and the CVSS impact.

Summary

A vulnerability was found in Netgear EX3700 up to 1.0.0.88. It has been classified as critical. Affected is the function sub_41619C of the file /mtd. The manipulation leads to stack-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.0.98 is able to address this issue. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01119 66th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
NETGEAREX37001.0.0.0; 1.0.0.1; 1.0.0.2; 1.0.0.3; 1.0.0.4; 1.0.0.5; 1.0.0.6; 1.0.0.7; 1.0.0.8; 1.0.0.9; 1.0.0.10; 1.0.0.11; 1.0.0.12; 1.0.0.13; 1.0.0.14; 1.0.0.15; 1.0.0.16; 1.0.0.17; 1.0.0.18; 1.0.0.19; 1.0.0.20; 1.0.0.21; 1.0.0.22; 1.0.0.23; 1.0.0.24; 1.0.0.25; 1.0.0.26; 1.0.0.27; 1.0.0.28; 1.0.0.29; 1.0.0.30; 1.0.0.31; 1.0.0.32; 1.0.0.33; 1.0.0.34; 1.0.0.35; 1.0.0.36; 1.0.0.37; 1.0.0.38; 1.0.0.39; 1.0.0.40; 1.0.0.41; 1.0.0.42; 1.0.0.43; 1.0.0.44; 1.0.0.45; 1.0.0.46; 1.0.0.47; 1.0.0.48; 1.0.0.49; 1.0.0.50; 1.0.0.51; 1.0.0.52; 1.0.0.53; 1.0.0.54; 1.0.0.55; 1.0.0.56; 1.0.0.57; 1.0.0.58; 1.0.0.59; 1.0.0.60; 1.0.0.61; 1.0.0.62; 1.0.0.63; 1.0.0.64; 1.0.0.65; 1.0.0.66; 1.0.0.67; 1.0.0.68; 1.0.0.69; 1.0.0.70; 1.0.0.71; 1.0.0.72; 1.0.0.73; 1.0.0.74; 1.0.0.75; 1.0.0.76; 1.0.0.77; 1.0.0.78; 1.0.0.79; 1.0.0.80; 1.0.0.81; 1.0.0.82; 1.0.0.83; 1.0.0.84; 1.0.0.85; 1.0.0.86; 1.0.0.87; 1.0.0.88—No fix listedCNA
  • EX3700 VendorNETGEAR Affected 1.0.0.0; 1.0.0.1; 1.0.0.2; 1.0.0.3; 1.0.0.4; 1.0.0.5; 1.0.0.6; 1.0.0.7; 1.0.0.8; 1.0.0.9; 1.0.0.10; 1.0.0.11; 1.0.0.12; 1.0.0.13; 1.0.0.14; 1.0.0.15; 1.0.0.16; 1.0.0.17; 1.0.0.18; 1.0.0.19; 1.0.0.20; 1.0.0.21; 1.0.0.22; 1.0.0.23; 1.0.0.24; 1.0.0.25; 1.0.0.26; 1.0.0.27; 1.0.0.28; 1.0.0.29; 1.0.0.30; 1.0.0.31; 1.0.0.32; 1.0.0.33; 1.0.0.34; 1.0.0.35; 1.0.0.36; 1.0.0.37; 1.0.0.38; 1.0.0.39; 1.0.0.40; 1.0.0.41; 1.0.0.42; 1.0.0.43; 1.0.0.44; 1.0.0.45; 1.0.0.46; 1.0.0.47; 1.0.0.48; 1.0.0.49; 1.0.0.50; 1.0.0.51; 1.0.0.52; 1.0.0.53; 1.0.0.54; 1.0.0.55; 1.0.0.56; 1.0.0.57; 1.0.0.58; 1.0.0.59; 1.0.0.60; 1.0.0.61; 1.0.0.62; 1.0.0.63; 1.0.0.64; 1.0.0.65; 1.0.0.66; 1.0.0.67; 1.0.0.68; 1.0.0.69; 1.0.0.70; 1.0.0.71; 1.0.0.72; 1.0.0.73; 1.0.0.74; 1.0.0.75; 1.0.0.76; 1.0.0.77; 1.0.0.78; 1.0.0.79; 1.0.0.80; 1.0.0.81; 1.0.0.82; 1.0.0.83; 1.0.0.84; 1.0.0.85; 1.0.0.86; 1.0.0.87; 1.0.0.88 Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:o:netgear:ex3700_firmware:*:*:*:*:*:*:*:*before 1.0.0.88VulnerableNETGEAR
cpe:2.3:h:netgear:ex3700:-:*:*:*:*:*:*:*not specified by NVDRunning onNETGEAR
  • cpe:2.3:o:netgear:ex3700_firmware:*:*:*:*:*:*:*:* Versions before 1.0.0.88 Vulnerable ·NETGEAR
  • cpe:2.3:h:netgear:ex3700:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NETGEAR

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-5934
  2. 2026-10-03 Alias added: GHSA-942c-3x7c-8jqx

References

  • TI-2022-10624 Buffer overflow in NETGEAR R6700v3 CVSS 3.1HIGH 8.8
  • TI-2021-13978 Stack-based buffer overflow in NETGEAR R6400v2 CVSS 3.1HIGH 8.8
  • TI-2021-20708 Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. CVSS 3.1CRITICAL 9.8
  • TI-2020-18240 Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. CVSS 3.1CRITICAL 9.8
  • TI-2018-15096 Certain NETGEAR devices are affected by a stack-based buffer overflow by an… CVSS 3.1CRITICAL 9.8
  • TI-2020-18244 Certain NETGEAR devices are affected by incorrect configuration of security settings. CVSS 3.1CRITICAL 9.4
See all 42 →

Sources