PPWP < 1.9.11 - Subscriber+ Access Bypass via REST API
Priority MEDIUM 62Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The PPWP – Password Protect Pages WordPress plugin before version 1.9.11 allows to put the site content behind a password authorization, however users with subscriber or greater roles can view content via the REST API.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00347 28th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed PPWP – Password Protect Pages (Unknown): 1.9.11
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | PPWP – Password Protect Pages | before 1.9.11 | 1.9.11 | Patch available | CNA |
- PPWP – Password Protect Pages VendorUnknown Affected before 1.9.11 Fixed in 1.9.11 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:passwordprotectwp:password_protect_wordpress:*:*:*:*:*:wordpress:*:* | before 1.9.11 | Vulnerable | Passwordprotectwp |
- cpe:2.3:a:passwordprotectwp:password_protect_wordpress:*:*:*:*:*:wordpress:*:* Versions before 1.9.11 Vulnerable ·Passwordprotectwp
Remediation
- Fix · CNA PPWP – Password Protect Pages (Unknown) Fixed in 1.9.11
Timeline
- 2026-10-02 Threatist record created from CVE-2025-5998
- 2026-10-03 Alias added: GHSA-858f-824m-5p75
References
More Passwordprotectwp Password Protect Wordpress vulnerabilities
- TI-2022-04227 PPWP – WordPress Password Protect Page < 1.8.6 - Contributor+ Stored XSS in Shortcode CVSS 3.1MEDIUM 5.4
- TI-2024-00575 PPWP – Password Protect Pages <= 1.8.9 - Protection Mechanism Bypass CVSS 3.1MEDIUM 5.3
Sources
- CVE-2025-5998 · CVE Program
- CVE-2025-5998 · NVD
- FIRST EPSS
- GHSA-858f-824m-5p75 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences