Read the docs
TI-2025-05443 Aliases CVE-2025-6024GHSA-ppc7-gg9m-7hwq

Cross-Site Scripting via Authentication Endpoint in Multiple WSO2 Products Allows Redirection to Malicious Websites

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The authentication endpoint fails to encode user-supplied input before rendering it in the web page, allowing for script injection. An attacker can leverage this by injecting malicious scripts into the authentication endpoint. This can result in the user's browser being redirected to a malicious website, manipulation of the web page's user interface, or the retrieval of information from the browser. However, session hijacking is not possible due to the httpOnly flag protecting session-related cookies.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0023 13th percentileScored 2026-11-07
Fix Fixed WSO2 API Manager (WSO2): 3.1.0.351, 3.2.0.455, 3.2.1.74 +2WSO2 Identity Server (WSO2): 5.10.0.360, 5.11.0.405

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
WSO2WSO2 API Manager3.1.0 to before 3.1.0.351; 3.2.0 to before 3.2.0.455; 3.2.1 to before 3.2.1.74; 4.0.0 to before 4.0.0.375; 4.1.0 to before 4.1.0.2383.1.0.351, 3.2.0.455, 3.2.1.74, 4.0.0.375, 4.1.0.238Patch availableCNA
WSO2WSO2 Identity Server5.10.0 to before 5.10.0.360; 5.11.0 to before 5.11.0.4055.10.0.360, 5.11.0.405Patch availableCNA
  • WSO2 API Manager VendorWSO2 Affected 3.1.0 to before 3.1.0.351; 3.2.0 to before 3.2.0.455; 3.2.1 to before 3.2.1.74; 4.0.0 to before 4.0.0.375; 4.1.0 to before 4.1.0.238 Fixed in 3.1.0.351, 3.2.0.455, 3.2.1.74, 4.0.0.375, 4.1.0.238 Patch available CNA
  • WSO2 Identity Server VendorWSO2 Affected 5.10.0 to before 5.10.0.360; 5.11.0 to before 5.11.0.405 Fixed in 5.10.0.360, 5.11.0.405 Patch available CNA

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:a:wso2:api_manager:3.1.0:*:*:*:*:*:*:*3.1.0VulnerableWSO2
cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:*3.2.0VulnerableWSO2
cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:*3.2.1VulnerableWSO2
cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:*4.0.0VulnerableWSO2
cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:*4.1.0VulnerableWSO2
cpe:2.3:a:wso2:identity_server:5.10.0:*:*:*:*:*:*:*5.10.0VulnerableWSO2
cpe:2.3:a:wso2:identity_server:5.11.0:*:*:*:*:*:*:*5.11.0VulnerableWSO2
  • cpe:2.3:a:wso2:api_manager:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:identity_server:5.10.0:*:*:*:*:*:*:* Versions 5.10.0 Vulnerable ·WSO2
  • cpe:2.3:a:wso2:identity_server:5.11.0:*:*:*:*:*:*:* Versions 5.11.0 Vulnerable ·WSO2

Remediation

  • Fix · CNA WSO2 API Manager (WSO2) Fixed in 3.1.0.351, 3.2.0.455, 3.2.1.74, 4.0.0.375, 4.1.0.238
  • Fix · CNA WSO2 Identity Server (WSO2) Fixed in 5.10.0.360, 5.11.0.405

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-6024
  2. 2026-10-03 Alias added: GHSA-ppc7-gg9m-7hwq

References

  • TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
  • TI-2022-11928 Certain WSO2 products allow unrestricted file upload with resultant remote code execution. KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-15069 The Management Console in WSO2 API Manager through 3.1.0 and API Microgateway 2.2.0… CVSS 3.1CRITICAL 9.1
  • TI-2023-15163 A reflected cross-site scripting (XSS) vulnerability in /authenticationendpoint/login.do… CVSS 3.1MEDIUM 6.1
  • TI-2022-12002 A reflected XSS issue exists in the Management Console of several WSO2 products. CVSS 3.1MEDIUM 6.1
  • TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
See all 94 →

Sources