themanojdesai python-a2a api.py create_workflow path traversal
Key facts
- Attack vector
- Adjacent network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| themanojdesai | python-a2a | 0.5.0; 0.5.1; 0.5.2; 0.5.3; 0.5.4; 0.5.5 | 0.5.6 | Patch available | CNA |
| — | python-a2a (PyPI) | before 0.5.6 | 0.5.6 | Patch available | GHSA-rp38-pj7h-r8q2 |
- python-a2a Vendorthemanojdesai Affected 0.5.0; 0.5.1; 0.5.2; 0.5.3; 0.5.4; 0.5.5 Fixed in 0.5.6 Patch available CNA
- python-a2a (PyPI) Vendor— Affected before 0.5.6 Fixed in 0.5.6 Patch available GHSA-rp38-pj7h-r8q2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:themanojdesai:python_a2a:*:*:*:*:*:*:*:* | up to 0.5.5 | Vulnerable | themanojdesai |
- cpe:2.3:a:themanojdesai:python_a2a:*:*:*:*:*:*:*:* Versions up to 0.5.5 Vulnerable ·themanojdesai
Remediation
- Fix · CNA python-a2a (themanojdesai) Fixed in 0.5.6
- Fix · GHSA-rp38-pj7h-r8q2 python-a2a (PyPI) Fixed in 0.5.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-6167
- 2026-10-03 Alias added: GHSA-rp38-pj7h-r8q2
References
Exploit 2
Sources
- CVE-2025-6167 · CVE Program
- CVE-2025-6167 · NVD
- FIRST EPSS
- GHSA-rp38-pj7h-r8q2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences