ACAP applications can gain elevated privileges due to improper input validation…
Priority LOW 31CWE-1287Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
ACAP applications can gain elevated privileges due to improper input validation, potentially leading to privilege escalation. This vulnerability can only be exploited if the Axis device is configured to allow the installation of unsigned ACAP applications, and if an attacker convinces the victim to install a malicious ACAP application.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00146 3rd percentileScored 2026-11-07
Fix Fixed AXIS OS (Axis Communications AB): 12.6.28
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Axis Communications AB | AXIS OS | 12.0.0 to before 12.6.28 | 12.6.28 | Patch available | CNA |
- AXIS OS VendorAxis Communications AB Affected 12.0.0 to before 12.6.28 Fixed in 12.6.28 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:axis:axis_os:*:*:*:*:active:*:*:* | before 12.6.28 | Vulnerable | Axis Communications AB |
- cpe:2.3:o:axis:axis_os:*:*:*:*:active:*:*:* Versions before 12.6.28 Vulnerable ·Axis Communications AB
Remediation
- Fix · CNA AXIS OS (Axis Communications AB) Fixed in 12.6.28
Timeline
- 2026-10-02 Threatist record created from CVE-2025-6298
- 2026-10-03 Alias added: GHSA-4pr9-79mg-ghjx
References
More Axis Communications AB Axis Os vulnerabilities
- TI-2023-07814 Remote code execution vulnerability during the installation of ACAP applications on the Axis device CVSS 3.1CRITICAL 9.1
- TI-2025-00260 The VAPIX Device Configuration framework allowed a privilege escalation, enabling a… CVSS 3.1CRITICAL 9.4
- TI-2025-10210 OS command injection in AXIS OS CVSS 3.1HIGH 8.8
- TI-2023-05336 Insufficient input validation in VAPIX API create_overlay.cgi CVSS 3.1HIGH 8.8
- TI-2025-00291 Improper privilege management in AXIS OS CVSS 3.1HIGH 8.8
- TI-2021-11974 Injection in AXIS OS CVSS 3.1HIGH 8.8
Sources
- CVE-2025-6298 · CVE Program
- CVE-2025-6298 · NVD
- FIRST EPSS
- GHSA-4pr9-79mg-ghjx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences