Read the docs
TI-2025-05988 Aliases CVE-2025-6592GHSA-9r44-56w8-gqrx

Improper access control in Wikimedia Foundation AbuseFilter

Priority LOW 11CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-284.

Summary

Vulnerability in Wikimedia Foundation AbuseFilter. This vulnerability is associated with program files includes/auth/AuthManager.Php. This issue affects AbuseFilter: from fe0b1cb9e9691faf4d8d9bd80646589f6ec37615 before 1.43.2, 1.44.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00402 34th percentileScored 2026-11-07
Fix Fixed AbuseFilter (Wikimedia Foundation): 1.43.2, 1.44.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Wikimedia FoundationAbuseFilterfe0b1cb9e9691faf4d8d9bd80646589f6ec37615 to before 1.43.2, 1.44.01.43.2, 1.44.0Patch availableCNA
  • AbuseFilter VendorWikimedia Foundation Affected fe0b1cb9e9691faf4d8d9bd80646589f6ec37615 to before 1.43.2, 1.44.0 Fixed in 1.43.2, 1.44.0 Patch available CNA

Remediation

  • Fix · CNA AbuseFilter (Wikimedia Foundation) Fixed in 1.43.2, 1.44.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-6592
  2. 2026-10-03 Alias added: GHSA-9r44-56w8-gqrx

References

  • TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
  • TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
  • TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
  • TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
  • TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
  • TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
See all 255 →

Sources