"{{SITENAME}} registered email address has been changed" email sent to unverified email addresses
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/user/User.Php. This issue affects MediaWiki: from 1.27.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | MediaWiki | 1.27.0 to before 1.39.13, 1.42.7 1.43.2, 1.44.0 | 1.39.13, 1.42.7 1.43.2, 1.44.0 | Patch available | CNA |
- MediaWiki VendorWikimedia Foundation Affected 1.27.0 to before 1.39.13, 1.42.7 1.43.2, 1.44.0 Fixed in 1.39.13, 1.42.7 1.43.2, 1.44.0 Patch available CNA
Remediation
- Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.39.13, 1.42.7 1.43.2, 1.44.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Wikimedia Foundation MediaWiki 1.39.13, 1.42.7 1.43.2, 1.44.0
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2025-06299 Autoblocks from global account suppressions are publicly visiblePriority LOW 13
- TI-2025-05990 XSS in Special:ApiSandboxPriority LOW 3
- TI-2025-05987 HTML injection in API action=feedcontributions output from i18n messagePriority LOW 3
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-6593
- 2026-10-03 Alias added: GHSA-qr4c-wx99-f4h5
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2025-6593 · CVE Program
- CVE-2025-6593 · NVD
- FIRST EPSS
- GHSA-qr4c-wx99-f4h5 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-6593 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences