Read the docs
TI-2025-05993 Aliases CVE-2025-6597GHSA-xrvg-9c6x-8hxj

MediaWiki should not consider autocreation as login for the purposes of security reauthentication

Priority LOW 3CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Active
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/auth/AuthManager.Php. This issue affects MediaWiki: from * before 1.39.13, 1.42.7, 1.43.2, 1.44.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00508 43rd percentileScored 2026-11-07
Fix Fixed MediaWiki (Wikimedia Foundation): 1.39.13, 1.42.7, 1.43.2 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Wikimedia FoundationMediaWikibefore 1.39.13, 1.42.7, 1.43.2, 1.44.01.39.13, 1.42.7, 1.43.2, 1.44.0Patch availableCNA
  • MediaWiki VendorWikimedia Foundation Affected before 1.39.13, 1.42.7, 1.43.2, 1.44.0 Fixed in 1.39.13, 1.42.7, 1.43.2, 1.44.0 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*——mediawiki
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions — — ·mediawiki

Remediation

  • Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.39.13, 1.42.7, 1.43.2, 1.44.0

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-6597
  2. 2026-10-03 Alias added: GHSA-xrvg-9c6x-8hxj

References

  • TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
  • TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
  • TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
  • TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
  • TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
  • TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
See all 255 →

Sources