Opal Estate Pro <= 1.7.5 - Unauthenticated Privilege Escalation via 'on_regiser_user'
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
The Opal Estate Pro – Property Management and Submission plugin for WordPress, used by the FullHouse - Real Estate Responsive WordPress Theme, is vulnerable to privilege escalation via in all versions up to, and including, 1.7.5. This is due to a lack of role restriction during registration in the 'on_regiser_user' function. This makes it possible for unauthenticated attackers to arbitrarily choose the role, including the Administrator role, assigned when registering.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-6934
- 2026-10-03 Alias added: GHSA-9w3f-cw3m-94h4
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5d7b75a4-67b4-4347-91a6-dbf98da5ceaf?source=cve
- https://themeforest.net/item/fullhouse-real-estate-responsive-wordpress-theme/16179481
- https://plugins.trac.wordpress.org/browser/opal-estate-pro/trunk/inc/user/class-opalestate-user.php#L228
- https://plugins.trac.wordpress.org/browser/opal-estate-pro/trunk/inc/user/class-opalestate-user.php#L235
More wpopal vulnerabilities
- TI-2022-19335 Server Side Request Forgery (SSRF) vulnerability affecting multiple WordPress plugins CVSS 3.1CRITICAL 9.8
- TI-2025-17734 WordPress GG Bought Together for WooCommerce plugin <= 1.0.2 - SQL Injection Vulnerability CVSS 3.1CRITICAL 9.3
- TI-2025-30032 WordPress Opal Woo Custom Product Variation plugin <= 1.2.0 - Arbitrary File Deletion Vulnerability CVSS 3.1HIGH 8.6
- TI-2024-35115 WordPress Opal Woo Custom Product Variation plugin <= 1.1.3 - Arbitrary File Deletion vulnerability CVSS 3.1HIGH 7.5
- TI-2021-03244 Opal Estate <= 1.6.11 - Cross-Site Request Forgery Bypass CVSS 3.1HIGH 8.8
- TI-2023-06084 GTG Product Feed for Shopping <= 1.2.4 - Missing Authorization to Unauthenticated Plugin Settings Update CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-6934 · CVE Program
- CVE-2025-6934 · NVD
- FIRST EPSS
- GHSA-9w3f-cw3m-94h4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences