Insufficient Granularity of Access Control in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An issue has been discovered in GitLab CE/EE affecting all versions from 15.0 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that could have allowed priviledged users to access certain resource_group information through the API which should have been unavailable.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 15.0 to before 18.0.5; 18.1 to before 18.1.3; 18.2 to before 18.2.1 | 18.0.5, 18.1.3, 18.2.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 15.0 to before 18.0.5; 18.1 to before 18.1.3; 18.2 to before 18.2.1 Fixed in 18.0.5, 18.1.3, 18.2.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.0.0 to before 18.0.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.0.0 to before 18.0.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.1.0 to before 18.1.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.1.0 to before 18.1.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.2:*:*:*:community:*:*:* | 18.2 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.2:*:*:*:enterprise:*:*:* | 18.2 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.0.0 to before 18.0.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.0.0 to before 18.0.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.1.0 to before 18.1.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.1.0 to before 18.1.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.2:*:*:*:community:*:*:* Versions 18.2 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.2:*:*:*:enterprise:*:*:* Versions 18.2 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 18.0.5, 18.1.3, 18.2.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 18.0.5, 18.1.3, 18.2.1
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2025-04460 Exposure of Sensitive Information Due to Incompatible Policies in GitLabPriority LOW 25
- TI-2025-01112 Missing Authorization in GitLabPriority LOW 20
- TI-2025-00652 Incorrect Authorization in GitLabPriority LOW 20
Timeline
- 2026-10-02 Threatist record created from CVE-2025-7001
- 2026-10-03 Alias added: GHSA-w44h-qxhv-wqww
References
Exploit 1
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-7001 · CVE Program
- CVE-2025-7001 · NVD
- FIRST EPSS
- GHSA-w44h-qxhv-wqww · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences