Privilege Escalation in MAAS via Websocket Request Manipulation
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
An Improper Input Validation vulnerability exists in the user websocket handler of MAAS. An authenticated, unprivileged attacker can intercept a user.update websocket request and inject the is_superuser property set to true. The server improperly validates this input, allowing the attacker to self-promote to an administrator role. This results in full administrative control over the MAAS deployment.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ubuntu | MAAS | 3.3.0 to before 3.3.11; 3.4.0 to before 3.4.9; 3.5.0 to before 3.5.9; 3.6.0 to before 3.6.2 | 3.3.11, 3.4.9, 3.5.9, 3.6.2, 3.7.0, 3.8.0 | Patch available | CNA |
- MAAS VendorUbuntu Affected 3.3.0 to before 3.3.11; 3.4.0 to before 3.4.9; 3.5.0 to before 3.5.9; 3.6.0 to before 3.6.2 Fixed in 3.3.11, 3.4.9, 3.5.9, 3.6.2, 3.7.0, 3.8.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:canonical:maas:*:*:*:*:*:*:*:* | 3.3.0 to before 3.3.11; 3.4.0 to before 3.4.9; 3.5.0 to before 3.5.9; 3.6.0 to before 3.6.2 | Vulnerable | Canonical |
- cpe:2.3:a:canonical:maas:*:*:*:*:*:*:*:* Versions 3.3.0 to before 3.3.11; 3.4.0 to before 3.4.9; 3.5.0 to before 3.5.9; 3.6.0 to before 3.6.2 Vulnerable ·Canonical
Remediation
- Fix · CNA MAAS (Ubuntu) Fixed in 3.3.11, 3.4.9, 3.5.9, 3.6.2, 3.7.0, 3.8.0
Timeline
- 2026-10-02 Threatist record created from CVE-2025-7044
- 2026-10-03 Alias added: GHSA-6rm3-6fxh-j77h
References
More Ubuntu vulnerabilities
- TI-2021-02452 Incorrect authorization in Ubuntu linux kernel KEVCVSS 3.1HIGH 8.8
- TI-2007-05153 Stack-based buffer overflow in the cons_options function in options.c in dhcpd in OpenBSD… CVSS 2.0HIGH 7.2
- TI-2004-01032 Multiple vulnerabilities in the IGMP functionality for Linux kernel 2.4.22 to 2.4.28, and… CVSS 2.0HIGH 10.0
- TI-2004-00896 Multiple buffer overflows in libXML 2.6.12 and 2.6.13 (libxml2), and possibly other… CVSS 2.0HIGH 10.0
- TI-2004-00800 Buffer overflow in the QFILEPATHINFO request handler in Samba 3.0.x through 3.0.7 may… CVSS 2.0HIGH 10.0
- TI-2004-00962 Buffer overflow in the exif_read_data function in PHP before 4.3.10 and PHP 5.x up to… CVSS 2.0HIGH 10.0
Sources
- CVE-2025-7044 · CVE Program
- CVE-2025-7044 · NVD
- FIRST EPSS
- GHSA-6rm3-6fxh-j77h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences