Cross-site scripting in dotrex PowerFolio – Portfolio & Image Gallery for Elementor
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Portfolio for Elementor & Image Gallery | PowerFolio plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS Attributes of Plugin's widgets in all versions up to, and including, 3.2.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The issue was partially fixed in version 3.2.0 and fully fixed in version 3.2.1
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| dotrex | PowerFolio – Portfolio & Image Gallery for Elementor | up to 3.2.0 | — | No fix listed | CNA |
- PowerFolio – Portfolio & Image Gallery for Elementor Vendordotrex Affected up to 3.2.0 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pwrplugins:powerfolio:*:*:*:*:*:wordpress:*:* | before 3.2.1 | Vulnerable | PWR Plugins |
- cpe:2.3:a:pwrplugins:powerfolio:*:*:*:*:*:wordpress:*:* Versions before 3.2.1 Vulnerable ·PWR Plugins
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-7046
- 2026-10-03 Alias added: GHSA-r4xf-w6r8-v332
References
More dotrex vulnerabilities
- TI-2022-04562 Freemius SDK <= 2.4.2 - Missing Authorization Checks CVSS 3.1MEDIUM 6.3
Sources
- CVE-2025-7046 · CVE Program
- CVE-2025-7046 · NVD
- FIRST EPSS
- GHSA-r4xf-w6r8-v332 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences