Cockpit save cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79 and CWE-94.
Summary
A vulnerability was found in Cockpit up to 2.11.3. It has been rated as problematic. This issue affects some unknown processing of the file /system/users/save. The manipulation of the argument name/email leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 is able to address this issue. The patch is named bdcd5e3bc651c0839c7eea807f3eb6af856dbc76. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted very professional. A patch and new release was made available very quickly.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Cockpit | 2.11.0; 2.11.1; 2.11.2; 2.11.3 | 2.11.4 | Patch available | CNA |
| — | cockpit-hq/cockpit (Packagist) | before 2.11.4 | 2.11.4 | Patch available | GHSA-j4rj-fgcq-wmqp |
- Cockpit Vendor— Affected 2.11.0; 2.11.1; 2.11.2; 2.11.3 Fixed in 2.11.4 Patch available CNA
- cockpit-hq/cockpit (Packagist) Vendor— Affected before 2.11.4 Fixed in 2.11.4 Patch available GHSA-j4rj-fgcq-wmqp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:agentejo:cockpit:*:*:*:*:*:*:*:* | up to 2.11.3 | Vulnerable | cockpit-hq |
- cpe:2.3:a:agentejo:cockpit:*:*:*:*:*:*:*:* Versions up to 2.11.3 Vulnerable ·cockpit-hq
Remediation
- Fix · CNA Cockpit Fixed in 2.11.4
- Fix · GHSA-j4rj-fgcq-wmqp cockpit-hq/cockpit (Packagist) Fixed in 2.11.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-7053
- 2026-10-03 Alias added: GHSA-j4rj-fgcq-wmqp
References
More cockpit-hq Cockpit vulnerabilities
- TI-2020-18291 Agentejo Cockpit before 0.11.2 allows NoSQL injection via the Controller/Auth.php resetpassword function. CVSS 3.1CRITICAL 9.8
- TI-2020-18290 Agentejo Cockpit before 0.11.2 allows NoSQL injection via the Controller/Auth.php check function. CVSS 3.1CRITICAL 9.8
- TI-2022-02511 Insufficient Session Expiration in cockpit-hq/cockpit CVSS 3.1CRITICAL 9.8
- TI-2020-18292 Agentejo Cockpit before 0.11.2 allows NoSQL injection via the Controller/Auth.php newpassword function. CVSS 3.1CRITICAL 9.8
- TI-2023-19207 A Cross-Site Request Forgery (CSRF) in the Admin portal of Cockpit CMS v2.5.2 allows… CVSS 3.1HIGH 8.8
- TI-2023-01240 Unrestricted Upload of File with Dangerous Type in cockpit-hq/cockpit CVSS 3.1HIGH 8.8
Sources
- CVE-2025-7053 · CVE Program
- CVE-2025-7053 · NVD
- FIRST EPSS
- GHSA-j4rj-fgcq-wmqp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences