Cross-site scripting in marceljm Featured Image from URL
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Featured Image from URL (FIFU) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via a post's Featured Image custom fields in all versions up to, and including, 5.2.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in version 5.2.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-7400
- 2026-10-03 Alias added: GHSA-wcvg-98r2-g94v
References
More marceljm vulnerabilities
- TI-2025-09165 Featured Image from URL (FIFU) <= 5.2.7 - Unauthenticated Information Exposure via Log File CVSS 3.1MEDIUM 5.3
- TI-2025-09213 Featured Image from URL (FIFU) <= 5.2.7 - Authenticated (Admin+) SQL Injection CVSS 3.1MEDIUM 4.9
- TI-2025-09212 Featured Image from URL (FIFU) <= 5.2.7 - Authenticated (Admin+) SQL Injection CVSS 3.1MEDIUM 4.9
- TI-2025-09164 Featured Image from URL (FIFU) <= 5.2.7 - Missing Authorization to Password Protected Post Disclosure CVSS 3.1MEDIUM 5.3
- TI-2025-12244 Featured Image from URL (FIFU) <= 5.3.1 - Authenticated (Contributor+) Server-Side Request Forgery via 'fifu_input_url' CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-7400 · CVE Program
- CVE-2025-7400 · NVD
- FIRST EPSS
- GHSA-wcvg-98r2-g94v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences