Ebook Store < 5.8015 - Reflected XSS via $_SERVER['REQUEST_URI']
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Ebook Store WordPress plugin before 5.8015 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00242 15th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ebook Store (Unknown): 5.8015
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ebook Store | before 5.8015 | 5.8015 | Patch available | CNA |
- Ebook Store VendorUnknown Affected before 5.8015 Fixed in 5.8015 Patch available CNA
Remediation
- Fix · CNA Ebook Store (Unknown) Fixed in 5.8015
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8113
- 2026-10-03 Alias added: GHSA-wpqf-xvqm-p9f4
References
More motovnet Ebook Store vulnerabilities
- TI-2023-08876 WordPress Ebook Store plugin <= 5.775 - Broken Authentication vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-24405 WordPress Ebook Store Plugin <= 5.785 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-06089 Ebook Store <= 5.8001 - Unauthenticated Full Path Disclosure CVSS 3.1MEDIUM 5.3
- TI-2024-11373 Ebook Store <= 5.8001 - Reflected Cross-Site Scripting via 'step' CVSS 3.1MEDIUM 6.1
- TI-2024-10457 Ebook Store <= 5.8001 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-08865 WordPress Ebook Store Plugin <= 5.775 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2025-8113 · CVE Program
- CVE-2025-8113 · NVD
- FIRST EPSS
- GHSA-wpqf-xvqm-p9f4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences