Read the docs
TI-2025-07560 Aliases CVE-2025-8260GHSA-8rhv-2p84-6g62

Vaelsys VaelsysV4 Web interface vgrid_server.php weak hash

Priority MEDIUM 45CWE-327Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Attack requirements
None
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-327.

Summary

A security flaw has been discovered in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. This affects an unknown part of the file /grid/vgrid_server.php of the component Web interface. Performing a manipulation of the argument xajaxargs results in use of weak hash. The attack is possible to be carried out remotely. The complexity of an attack is rather high. It is indicated that the exploitability is difficult. The exploit has been released to the public and may be used for attacks. Upgrading to version 5.1.1 and 5.4.1 is able to mitigate this issue. Upgrading the affected component is recommended.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00274 19th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed VaelsysV4 (Vaelsys): 5.1.1, 5.4.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
VaelsysVaelsysV45.0; 5.1; 5.1.0; 5.2; 5.3; 5.4.05.1.1, 5.4.1Patch availableCNA
  • VaelsysV4 VendorVaelsys Affected 5.0; 5.1; 5.1.0; 5.2; 5.3; 5.4.0 Fixed in 5.1.1, 5.4.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vaelsys:vaelsys:4.1.0:*:*:*:*:*:*:*4.1.0VulnerableVaelsys
  • cpe:2.3:a:vaelsys:vaelsys:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Vaelsys

Remediation

  • Fix · CNA VaelsysV4 (Vaelsys) Fixed in 5.1.1, 5.4.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-8260
  2. 2026-10-03 Alias added: GHSA-8rhv-2p84-6g62

References

  • TI-2026-02544 Vaelsys HTTP POST Request tree_server.php os command injection CVSS 4.0MEDIUM 6.9
  • TI-2025-07561 Vaelsys VaelsysV4 User Creation vgrid_server.php improper authorization CVSS 4.0MEDIUM 6.9
  • TI-2025-07559 Vaelsys VaelsysV4 Web interface vgrid_server.php execute_DataObjectProc os command injection CVSS 4.0MEDIUM 6.9

Sources