Improper input validation in Concrete CMS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Concrete CMS 9 to 9.4.2 and versions below 8.5.21 are vulnerable to Reflected Cross-Site Scripting (XSS) in the Conversation Messages Dashboard Page. Unsanitized input could cause theft of session cookies or tokens, defacement of web content, redirection to malicious sites, and (if victim is an admin), the execution of unauthorized actions. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks Fortbridge https://fortbridge.co.uk/ for performing a penetration test and vulnerability assessment on Concrete CMS and reporting this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Concrete CMS | Concrete CMS | 9.0.0 to before 9.4.3; 5.6 to before 8.5.21 | 9.4.3, 8.5.21 | Patch available | CNA |
| — | concrete5/concrete5 (Packagist) | before 8.5.21 | 8.5.21 | Patch available | GHSA-4pcg-pjp5-3mc6 |
| — | concrete5/concrete5 (Packagist) | 9.0.0RC1 to before 9.4.3 | 9.4.3 | Patch available | GHSA-4pcg-pjp5-3mc6 |
- Concrete CMS VendorConcrete CMS Affected 9.0.0 to before 9.4.3; 5.6 to before 8.5.21 Fixed in 9.4.3, 8.5.21 Patch available CNA
- concrete5/concrete5 (Packagist) Vendor— Affected before 8.5.21 Fixed in 8.5.21 Patch available GHSA-4pcg-pjp5-3mc6
- concrete5/concrete5 (Packagist) Vendor— Affected 9.0.0RC1 to before 9.4.3 Fixed in 9.4.3 Patch available GHSA-4pcg-pjp5-3mc6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* | before 8.5.21; 9.0 to before 9.4.3 | Vulnerable | Concrete CMS |
- cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:* Versions before 8.5.21; 9.0 to before 9.4.3 Vulnerable ·Concrete CMS
Remediation
- Fix · CNA Concrete CMS (Concrete CMS) Fixed in 9.4.3, 8.5.21
- Fix · GHSA-4pcg-pjp5-3mc6 concrete5/concrete5 (Packagist) Fixed in 8.5.21 Advisory →
- Fix · GHSA-4pcg-pjp5-3mc6 concrete5/concrete5 (Packagist) Fixed in 9.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8571
- 2026-10-03 Alias added: GHSA-4pcg-pjp5-3mc6
References
Other 6
- https://documentation.concretecms.org/developers/introduction/version-history/8521-release-notes
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/943-release-notes
- https://www.concretecms.org/download
- https://github.com/concretecms/concretecms/commit/4b39dcc17c309dc82eb8398e8cdb146942f62f92
- https://github.com/concretecms/concretecms/commit/f7630b467d3a234d3d333ca117046a500e7ee2b6
- https://github.com/concretecms/concretecms
More Concrete Cms vulnerabilities
- TI-2026-23602 ConcreteCMS v9.4.7 contains a Denial of Service (DoS) vulnerability in the File Manager… CVSS 3.1MEDIUM 6.5
- TI-2023-23992 A Cross Site Scripting (XSS) vulnerability in Concrete CMS from versions 9.2.0 to 9.2.2… CVSS 3.1MEDIUM 5.4
- TI-2023-26495 Concrete CMS before 8.5.13 and 9.x before 9.2.2 allows unauthorized access because… CVSS 3.1CRITICAL 9.8
- TI-2026-14907 Missing authorization in Concrete CMS CVSS 4.0HIGH 8.7
- TI-2022-06200 Cleartext transmission of sensitive information in https://github.com/concrete5/concrete5 CVSS 3.1CRITICAL 9.8
- TI-2021-17294 An issue was discovered in Concrete CMS through 8.5.5. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-8571 · CVE Program
- CVE-2025-8571 · NVD
- FIRST EPSS
- GHSA-4pcg-pjp5-3mc6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences