Resource exhaustion via malformed DNSKEY handling
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
Querying for records within a specially crafted zone containing certain malformed DNSKEY records can lead to CPU exhaustion. This issue affects BIND 9 versions 9.18.0 through 9.18.39, 9.20.0 through 9.20.13, 9.21.0 through 9.21.12, 9.18.11-S1 through 9.18.39-S1, and 9.20.9-S1 through 9.20.13-S1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ISC | BIND 9 | 9.18.0 – 9.18.39; 9.20.0 – 9.20.13; 9.21.0 – 9.21.12; 9.18.11-S1 – 9.18.39-S1; 9.20.9-S1 – 9.20.13-S1 | — | No fix listed | CNA |
- BIND 9 VendorISC Affected 9.18.0 – 9.18.39; 9.20.0 – 9.20.13; 9.21.0 – 9.21.12; 9.18.11-S1 – 9.18.39-S1; 9.20.9-S1 – 9.20.13-S1 Fixed in — No fix listed CNA
Remediation
Red Hat 16 advisories
- RHSA-2026:18786 Released 2026-05-19 · Red Hat rating Importantbind security update
- Red Hat Enterprise Linux AppStream (v. 9) bind-32:9.16.23-40.el9_8.1, bind-chroot-32:9.16.23-40.el9_8.1, bind-dnssec-doc-32:9.16.23-40.el9_8.1 +5
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) bind-devel-32:9.16.23-40.el9_8.1, bind-doc-32:9.16.23-40.el9_8.1, bind-libs-32:9.16.23-40.el9_8.1
- RHSA-2026:6935 Released 2026-04-07 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images bind-9.18.48-1.hum1@aarch64, bind-9.18.48-1.hum1@src, bind-9.18.48-1.hum1@x86_64 +12
- RHSA-2026:1541 Released 2026-02-05 · Red Hat rating ImportantOpenShift Container Platform 4.15.61 bug fix and security update
- Red Hat OpenShift Container Platform 4.15 rhcos-aarch64-415.92.202601271320-0, rhcos-ppc64le-415.92.202601271320-0, rhcos-s390x-415.92.202601271320-0 +1
Show 13 more Red Hat advisories
- RHSA-2026:0996 Released 2026-01-30 · Red Hat rating ImportantOpenShift Container Platform 4.14.61 bug fix and security update
- Red Hat OpenShift Container Platform 4.14 rhcos-aarch64-414.92.202601191325-0, rhcos-ppc64le-414.92.202601191325-0, rhcos-s390x-414.92.202601191325-0 +1
- RHSA-2026:0674 Released 2026-01-22 · Red Hat rating ImportantOpenShift Container Platform 4.19.22 bug fix and security update
- Red Hat OpenShift Container Platform 4.19 rhcos-aarch64-4.19.9.6.202601130152-0, rhcos-ppc64le-4.19.9.6.202601130152-0, rhcos-s390x-4.19.9.6.202601130152-0 +1
- RHSA-2026:0677 Released 2026-01-22 · Red Hat rating ImportantOpenShift Container Platform 4.13.63 bug fix and security update
- Red Hat OpenShift Container Platform 4.13 rhcos-x86_64-413.92.202601130113-0
- RHSA-2026:0702 Released 2026-01-22 · Red Hat rating ImportantOpenShift Container Platform 4.17.47 bug fix and security update
- Red Hat OpenShift Container Platform 4.17 rhcos-aarch64-417.94.202601120213-0, rhcos-ppc64le-417.94.202601120213-0, rhcos-s390x-417.94.202601120213-0 +1
- RHSA-2026:0332 Released 2026-01-15 · Red Hat rating ImportantOpenShift Container Platform 4.18.31 bug fix and security update
- Red Hat OpenShift Container Platform 4.18 rhcos-aarch64-418.94.202601071817-0, rhcos-ppc64le-418.94.202601071817-0, rhcos-s390x-418.94.202601071817-0 +1
- RHSA-2026:0326 Released 2026-01-15 · Red Hat rating ImportantOpenShift Container Platform 4.16.55 bug fix and security update
- Red Hat OpenShift Container Platform 4.16 rhcos-aarch64-416.94.202601071926-0, rhcos-ppc64le-416.94.202601071926-0, rhcos-s390x-416.94.202601071926-0 +1
- RHSA-2026:0316 Released 2026-01-15 · Red Hat rating ImportantOpenShift Container Platform 4.12.84 bug fix and security update
- Red Hat OpenShift Container Platform 4.12 rhcos-x86_64-412.86.202601061735-0
- RHSA-2026:0420 Released 2026-01-14 · Red Hat rating ImportantOpenShift Container Platform 4.20.10 bug fix and security update
- Red Hat OpenShift Container Platform 4.20 rhcos-aarch64-4.20.9.6.202601052146-0, rhcos-ppc64le-4.20.9.6.202601052146-0, rhcos-s390x-4.20.9.6.202601052146-0 +1
- RHSA-2025:21994 Released 2025-11-24 · Red Hat rating ImportantA Subscription Management tool for finding and reporting Red Hat product usage
- Red Hat Discovery 2 registry.redhat.io/discovery/discovery-server-rhel9, registry.redhat.io/discovery/discovery-ui-rhel9
- RHSA-2025:21111 Released 2025-11-12 · Red Hat rating Importantbind9.18 security update
- Red Hat Enterprise Linux AppStream (v. 9) bind9.18-32:9.18.29-5.el9_7.2, bind9.18-chroot-32:9.18.29-5.el9_7.2, bind9.18-dnssec-utils-32:9.18.29-5.el9_7.2 +2
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) bind9.18-devel-32:9.18.29-5.el9_7.2, bind9.18-doc-32:9.18.29-5.el9_7.2, bind9.18-libs-32:9.18.29-5.el9_7.2
- RHSA-2025:21034 Released 2025-11-11 · Red Hat rating Importantbind security update
- Red Hat Enterprise Linux AppStream (v. 10) bind-32:9.18.33-10.el10_1.2, bind-chroot-32:9.18.33-10.el10_1.2, bind-dnssec-utils-32:9.18.33-10.el10_1.2 +3
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) bind-devel-32:9.18.33-10.el10_1.2, bind-doc-32:9.18.33-10.el10_1.2
- RHSA-2025:19950 Released 2025-11-10 · Red Hat rating Importantbind9.18 security update
- Red Hat Enterprise Linux AppStream (v. 9) bind9.18-32:9.18.29-4.el9_6.2, bind9.18-chroot-32:9.18.29-4.el9_6.2, bind9.18-dnssec-utils-32:9.18.29-4.el9_6.2 +2
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) bind9.18-devel-32:9.18.29-4.el9_6.2, bind9.18-doc-32:9.18.29-4.el9_6.2, bind9.18-libs-32:9.18.29-4.el9_6.2
- RHSA-2025:19912 Released 2025-11-06 · Red Hat rating Importantbind security update
- Red Hat Enterprise Linux AppStream (v. 10) bind-32:9.18.33-4.el10_0.2, bind-chroot-32:9.18.33-4.el10_0.2, bind-dnssec-utils-32:9.18.33-4.el10_0.2 +3
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) bind-devel-32:9.18.33-4.el10_0.2, bind-doc-32:9.18.33-4.el10_0.2
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Discovery 2 | Fixed | RHSA-2025:21994 |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2025:19912, RHSA-2025:21034 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:19950, RHSA-2025:21111, RHSA-2026:18786 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2025:19912, RHSA-2025:21034 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) | Fixed | RHSA-2025:19950, RHSA-2025:21111, RHSA-2026:18786 |
| Red Hat Hardened Images | Fixed | RHSA-2026:6935 |
| Red Hat OpenShift Container Platform 4.12 | Fixed | RHSA-2026:0316 |
| Red Hat OpenShift Container Platform 4.13 | Fixed | RHSA-2026:0677 |
| Red Hat OpenShift Container Platform 4.14 | Fixed | RHSA-2026:0996 |
| Red Hat OpenShift Container Platform 4.15 | Fixed | RHSA-2026:1541 |
| Red Hat OpenShift Container Platform 4.16 | Fixed | RHSA-2026:0326 |
| Red Hat OpenShift Container Platform 4.17 | Fixed | RHSA-2026:0702 |
| Red Hat OpenShift Container Platform 4.18 | Fixed | RHSA-2026:0332 |
| Red Hat OpenShift Container Platform 4.19 | Fixed | RHSA-2026:0674 |
| Red Hat OpenShift Container Platform 4.20 | Fixed | RHSA-2026:0420 |
Not affected: 5 products
- Red Hat Discovery 2
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8677
- 2026-10-03 Alias added: GHSA-924g-f9mr-cm6x
- 2026-11-05 Affected versions changed · Red Hat
References
Advisory 1
More ISC vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
Sources
- CVE-2025-8677 · CVE Program
- CVE-2025-8677 · NVD
- FIRST EPSS
- GHSA-924g-f9mr-cm6x · GitHub Advisory Database · CC BY 4.0
- CVE-2025-8677 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences