Read the docs
TI-2025-08051 Aliases CVE-2025-8800GHSA-hw62-xfc6-h8r3

Open5GS AMF esm-handler.c esm_handle_pdn_connectivity_request denial of service

Priority HIGH 70CWE-404Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-404.

Summary

A vulnerability has been found in Open5GS up to 2.7.5. Affected by this issue is the function esm_handle_pdn_connectivity_request of the file src/mme/esm-handler.c of the component AMF Component. The manipulation leads to denial of service. The attack may be launched remotely. Upgrading to version 2.7.6 is able to address this issue. The name of the patch is 701505102f514cbde2856cd2ebc9bedb7efc820d. It is recommended to upgrade the affected component.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00649 51st percentileScored 2026-11-07
Fix Fixed Open5GS: 2.7.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Open5GS2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.52.7.6Patch availableCNA
  • Open5GS Vendor— Affected 2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.5 Fixed in 2.7.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:open5gs:open5gs:*:*:*:*:*:*:*:*before 2.7.6VulnerableOpen5GS
  • cpe:2.3:a:open5gs:open5gs:*:*:*:*:*:*:*:* Versions before 2.7.6 Vulnerable ·Open5GS

Remediation

  • Fix · CNA Open5GS Fixed in 2.7.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-8800
  2. 2026-10-03 Alias added: GHSA-hw62-xfc6-h8r3
  3. 2026-10-31 EPSS moved to the 50th–90th percentile

References

  • TI-2024-26883 open5gs v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
  • TI-2024-26882 Open5GS v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
  • TI-2024-22649 Open5GS MME versions <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
  • TI-2023-18757 Open5GS MME versions <= 2.6.4 contain a reachable assertion in the `Uplink NAS Transport`… CVSS 3.1HIGH 8.6
  • TI-2023-18755 Open5GS MME version <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
  • TI-2023-18754 Open5GS MME versions <= 2.6.4 contain an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
See all 153 →

Sources