Open5GS SMF smf-sm.c smf_state_operational denial of service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-404.
Summary
A vulnerability was determined in Open5GS up to 2.7.5. This vulnerability affects the function smf_state_operational of the file src/smf/smf-sm.c of the component SMF. The manipulation of the argument stream leads to denial of service. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version v2.7.6 is able to address this issue. The patch is identified as f168f7586a4fa536cee95ae60ac437d997f15b97. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Open5GS | 2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.5 | v2.7.6 | Patch available | CNA |
- Open5GS Vendor— Affected 2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.5 Fixed in v2.7.6 Patch available CNA
Remediation
- Fix · CNA Open5GS Fixed in v2.7.6
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8802
- 2026-10-03 Alias added: GHSA-4pwr-crv6-7pr9
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
Patch 2
More Open5gs vulnerabilities
- TI-2024-26883 open5gs v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
- TI-2024-26882 Open5GS v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
- TI-2024-22649 Open5GS MME versions <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
- TI-2023-18757 Open5GS MME versions <= 2.6.4 contain a reachable assertion in the `Uplink NAS Transport`… CVSS 3.1HIGH 8.6
- TI-2023-18755 Open5GS MME version <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
- TI-2023-18754 Open5GS MME versions <= 2.6.4 contain an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
Sources
- CVE-2025-8802 · CVE Program
- CVE-2025-8802 · NVD
- FIRST EPSS
- GHSA-4pwr-crv6-7pr9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences