Read the docs
TI-2025-08056 Aliases CVE-2025-8805GHSA-4m36-8fxx-9c3r

Open5GS SMF gsm-sm.c smf_gsm_state_wait_pfcp_deletion denial of service

Priority HIGH 70CWE-404Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-404.

Summary

A vulnerability was determined in Open5GS up to 2.7.5. Affected by this issue is the function smf_gsm_state_wait_pfcp_deletion of the file src/smf/gsm-sm.c of the component SMF. The manipulation leads to denial of service. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.7.6 is able to address this issue. The patch is identified as c58b8f081986aaf2a312d73a0a17985518b47fe6. It is recommended to upgrade the affected component.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00804 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Open5GS: 2.7.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Open5GS2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.52.7.6Patch availableCNA
  • Open5GS Vendor— Affected 2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.5 Fixed in 2.7.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:open5gs:open5gs:*:*:*:*:*:*:*:*before 2.7.6VulnerableOpen5GS
  • cpe:2.3:a:open5gs:open5gs:*:*:*:*:*:*:*:* Versions before 2.7.6 Vulnerable ·Open5GS

Remediation

  • Fix · CNA Open5GS Fixed in 2.7.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-8805
  2. 2026-10-03 Alias added: GHSA-4m36-8fxx-9c3r

References

  • TI-2024-26883 open5gs v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
  • TI-2024-26882 Open5GS v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
  • TI-2024-22649 Open5GS MME versions <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
  • TI-2023-18757 Open5GS MME versions <= 2.6.4 contain a reachable assertion in the `Uplink NAS Transport`… CVSS 3.1HIGH 8.6
  • TI-2023-18755 Open5GS MME version <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
  • TI-2023-18754 Open5GS MME versions <= 2.6.4 contain an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
See all 153 →

Sources