Insecure API Design in danny-avila/librechat
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In danny-avila/librechat version 0.7.9, there is an insecure API design issue in the 2-Factor Authentication (2FA) flow. The system allows users to disable 2FA without requiring a valid OTP or backup code, bypassing the intended verification process. This vulnerability occurs because the backend does not properly validate the OTP or backup code when the API endpoint '/api/auth/2fa/disable' is directly accessed. This flaw can be exploited by authenticated users to weaken the security of their own accounts, although it does not lead to full account compromise.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| danny-avila | danny-avila/librechat | before v0.8.0-rc2 | v0.8.0-rc2 | Patch available | CNA |
- danny-avila/librechat Vendordanny-avila Affected before v0.8.0-rc2 Fixed in v0.8.0-rc2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:librechat:librechat:0.7.9:-:*:*:*:*:*:* | 0.7.9 | Vulnerable | danny-avila |
- cpe:2.3:a:librechat:librechat:0.7.9:-:*:*:*:*:*:* Versions 0.7.9 Vulnerable ·danny-avila
Remediation
- Fix · CNA danny-avila/librechat (danny-avila) Fixed in v0.8.0-rc2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
danny-avila/librechat v0.8.0-rc2
2 records Highest priority Priority HIGH 1 HIGH, 1 LOW
Other records, highest priority first
- TI-2025-08100 Denial of Service in danny-avila/librechatPriority HIGH 66
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8850
- 2026-10-03 Alias added: GHSA-x5w7-gch7-xjf6
References
More danny-avila Librechat vulnerabilities
- TI-2026-25134 LibreChat Exfiltrates Server Secrets via MCP Server URL Injection CVSS 3.1CRITICAL 9.6
- TI-2026-17862 LibreChat MCP Stdio Remote Command Execution CVSS 3.1CRITICAL 9.9
- TI-2026-38976 LibreChat: Missing Resource Parameter Validation in MCP OAuth Flow CVSS 3.1CRITICAL 9.3
- TI-2024-27763 LibreChat through 0.7.4-rc1 has incorrect access control for message updates. CVSS 3.1CRITICAL 9.8
- TI-2024-10347 Path Traversal in danny-avila/librechat CVSS 3.0HIGH 8.8
- TI-2026-25682 In LibreChat 0.8.1-rc2, a logged-in user obtains a JWT for both the LibreChat API and the RAG API. CVSS 3.1CRITICAL 9.0
Sources
- CVE-2025-8850 · CVE Program
- CVE-2025-8850 · NVD
- FIRST EPSS
- GHSA-x5w7-gch7-xjf6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences