Doccure Core < 1.5.4 - Unauthenticated Privilege Escalation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
The Doccure Core plugin for WordPress is vulnerable to privilege escalation in versions up to, and excluding, 1.5.4. This is due to the plugin allowing users who are registering new accounts to set their own role or by supplying 'user_type' field. This makes it possible for unauthenticated attackers to gain elevated privileges by creating an account with the administrator role.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| dreamstechnologies | Doccure Core | before 1.5.4 | 1.5.4 | Patch available | CNA |
- Doccure Core Vendordreamstechnologies Affected before 1.5.4 Fixed in 1.5.4 Patch available CNA
Remediation
- Fix · CNA Doccure Core (dreamstechnologies) Fixed in 1.5.4
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8900
- 2026-10-03 Alias added: GHSA-x4c6-9vq7-8hcm
References
More dreamstechnologies vulnerabilities
- TI-2025-11891 Listee <= 1.1.6 - Unauthenticated Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2025-09833 Truelysell Core <= 1.8.6 - Unauthenticated Arbitrary User Password Change CVSS 3.1CRITICAL 9.8
- TI-2025-08355 Doccure Core <= 1.5.3 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2025-12442 Mentoring <= 1.2.8 - Unauthenticated Privilege Escalation in mentoring_process_registration CVSS 3.1CRITICAL 9.8
- TI-2025-08356 Doccure <= 1.5.0 - Unauthenticated Arbitrary User Password Change CVSS 3.1CRITICAL 9.8
- TI-2025-07850 Truelysell Core <= 1.8.7 - Unauthenticated Privilege Escalation via Registration CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-8900 · CVE Program
- CVE-2025-8900 · NVD
- FIRST EPSS
- GHSA-x4c6-9vq7-8hcm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences