OceanWP < 4.1.2 - Subscriber+ Limited Option Update
Priority MEDIUM 53CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
The OceanWP WordPress theme before 4.1.2 is vulnerable to an option update due to a missing capability check on one of its AJAX request handler, allowing any authenticated users, such as subscriber to update the darkMod` setting.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00232 14th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed OceanWP (Unknown): 4.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | OceanWP | before 4.1.2 | 4.1.2 | Patch available | CNA |
- OceanWP VendorUnknown Affected before 4.1.2 Fixed in 4.1.2 Patch available CNA
Remediation
- Fix · CNA OceanWP (Unknown) Fixed in 4.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2025-8944
- 2026-10-03 Alias added: GHSA-889q-5rwf-r9hj
References
More Oceanwp vulnerabilities
- TI-2025-08139 OceanWP <= 4.0.9 - 4.1.1 - Cross-Site Request Forgery to Ocean Extra Plugin Installation CVSS 3.1MEDIUM 4.3
Sources
- CVE-2025-8944 · CVE Program
- CVE-2025-8944 · NVD
- FIRST EPSS
- GHSA-889q-5rwf-r9hj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences