Read the docs
TI-2025-08357 Aliases CVE-2025-9115GHSA-vcp8-mq8x-mxp7

Etsy Shop < 3.0.7 - Reflected XSS via $_SERVER['REQUEST_URI']

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Etsy Shop WordPress plugin before 3.0.7 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.002 9th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Etsy Shop (Unknown): 3.0.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownEtsy Shopbefore 3.0.73.0.7Patch availableCNA
  • Etsy Shop VendorUnknown Affected before 3.0.7 Fixed in 3.0.7 Patch available CNA

Remediation

  • Fix · CNA Etsy Shop (Unknown) Fixed in 3.0.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-9115
  2. 2026-10-03 Alias added: GHSA-vcp8-mq8x-mxp7

References

Sources