Improper Privilege Management in Multiple WSO2 API Manager via keymanager-operations DCR Endpoint
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-306.
Summary
An improper privilege management vulnerability exists in WSO2 API Manager due to missing authentication and authorization checks in the keymanager-operations Dynamic Client Registration (DCR) endpoint. A malicious user can exploit this flaw to generate access tokens with elevated privileges, potentially leading to administrative access and the ability to perform unauthorized operations.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | WSO2 API Manager | 3.2.0 to before 3.2.0.437; 3.2.1 to before 3.2.1.57; 4.0.0 to before 4.0.0.357; 4.1.0 to before 4.1.0.221; 4.2.0 to before 4.2.0.159; 4.3.0 to before 4.3.0.72; 4.4.0 to before 4.4.0.35; 4.5.0 to before 4.5.0.19 | 3.2.0.437, 3.2.1.57, 4.0.0.357, 4.1.0.221, 4.2.0.159, 4.3.0.72, 4.4.0.35, 4.5.0.19 | Patch available | CNA |
| WSO2 | WSO2 API Control Plane | 4.5.0 to before 4.5.0.20 | 4.5.0.20 | Patch available | CNA |
- WSO2 API Manager VendorWSO2 Affected 3.2.0 to before 3.2.0.437; 3.2.1 to before 3.2.1.57; 4.0.0 to before 4.0.0.357; 4.1.0 to before 4.1.0.221; 4.2.0 to before 4.2.0.159; 4.3.0 to before 4.3.0.72; 4.4.0 to before 4.4.0.35; 4.5.0 to before 4.5.0.19 Fixed in 3.2.0.437, 3.2.1.57, 4.0.0.357, 4.1.0.221, 4.2.0.159, 4.3.0.72, 4.4.0.35, 4.5.0.19 Patch available CNA
- WSO2 API Control Plane VendorWSO2 Affected 4.5.0 to before 4.5.0.20 Fixed in 4.5.0.20 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wso2:api_control_plane:4.5.0:-:*:*:*:*:*:* | 4.5.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* | 4.2.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* | 4.3.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.4.0:-:*:*:*:*:*:* | 4.4.0 | Vulnerable | WSO2 |
| cpe:2.3:a:wso2:api_manager:4.5.0:-:*:*:*:*:*:* | 4.5.0 | Vulnerable | WSO2 |
- cpe:2.3:a:wso2:api_control_plane:4.5.0:-:*:*:*:*:*:* Versions 4.5.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.2.0:-:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.3.0:-:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.4.0:-:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·WSO2
- cpe:2.3:a:wso2:api_manager:4.5.0:-:*:*:*:*:*:* Versions 4.5.0 Vulnerable ·WSO2
Remediation
- Fix · CNA WSO2 API Manager (WSO2) Fixed in 3.2.0.437, 3.2.1.57, 4.0.0.357, 4.1.0.221, 4.2.0.159, 4.3.0.72, 4.4.0.35, 4.5.0.19
- Fix · CNA WSO2 API Control Plane (WSO2) Fixed in 4.5.0.20
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9152
- 2026-10-03 Alias added: GHSA-5w6w-g3g3-9qjv
References
More WSO2 Api Control Plane vulnerabilities
- TI-2026-04755 Authentication Bypass via JWT Algorithm Mismatch in Multiple WSO2 Products Allows Account Takeover KEVCVSS 3.1CRITICAL 10.0
- TI-2025-13722 Account Takeover via Conditional Authentication Script Logic in Multiple WSO2 Products CVSS 3.1CRITICAL 9.4
- TI-2025-09712 Potential Broken Access Control in Multiple WSO2 Products via System REST APIs CVSS 3.1CRITICAL 9.8
- TI-2026-01411 Privilege Escalation via System REST APIs in Multiple WSO2 Products Permits Admin Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08536 Improper Certificate-Based Authentication Enforcement in Multiple WSO2 Products CVSS 3.1CRITICAL 9.8
- TI-2026-03696 Denial of Service via Malicious JSON Payloads in Throttling Events in Multiple WSO2… CVSS 3.1HIGH 8.6
Sources
- CVE-2025-9152 · CVE Program
- CVE-2025-9152 · NVD
- FIRST EPSS
- GHSA-5w6w-g3g3-9qjv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences