Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2.2 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1 that could have allowed an authenticated user to achieve stored cross-site scripting by exploiting GitLab Flavored Markdown.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 18.2.2 to before 18.5.5; 18.6 to before 18.6.3; 18.7 to before 18.7.1 | 18.5.5, 18.6.3, 18.7.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 18.2.2 to before 18.5.5; 18.6 to before 18.6.3; 18.7 to before 18.7.1 Fixed in 18.5.5, 18.6.3, 18.7.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.2.2 to before 18.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.2.2 to before 18.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.6.0 to before 18.6.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.6.0 to before 18.6.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.7.0:*:*:*:community:*:*:* | 18.7.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:18.7.0:*:*:*:enterprise:*:*:* | 18.7.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.2.2 to before 18.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.2.2 to before 18.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.6.0 to before 18.6.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.6.0 to before 18.6.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.7.0:*:*:*:community:*:*:* Versions 18.7.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:18.7.0:*:*:*:enterprise:*:*:* Versions 18.7.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 18.5.5, 18.6.3, 18.7.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 18.5.5, 18.6.3, 18.7.1
6 records Highest priority Priority MEDIUM 1 MEDIUM, 5 LOW
Other records, highest priority first
- TI-2025-12588 Missing Authorization in GitLabPriority LOW 32
- TI-2025-12596 Missing Authorization in GitLabPriority LOW 29
- TI-2025-09672 Allocation of Resources Without Limits or Throttling in GitLabPriority LOW 29
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 2 products
- OpenShift Pipelines
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9222
- 2026-10-03 Alias added: GHSA-p9cp-qq4c-2wr5
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2025-9222 · CVE Program
- CVE-2025-9222 · NVD
- FIRST EPSS
- GHSA-p9cp-qq4c-2wr5 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-9222 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences