Deserialization of untrusted data in techjewel Fluent Forms – Customizable Contact Forms…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
The Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder plugin for WordPress is vulnerable to PHP Object Injection in versions 5.1.16 to 6.1.1 via deserialization of untrusted input in the parseUserProperties function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject a PHP Object. The additional presence of a POP chain allows attackers to read arbitrary files. If allow_url_include is enabled on the server, remote code execution is possible. While the vendor patched this issue in version 6.1.0, the patch caused a fatal error in the vulnerable code, due to a missing class import, so we consider 6.1.2 to be the most complete and best patched version
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| techjewel | Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder | 5.1.16 – 6.1.1 | — | No fix listed | CNA |
- Fluent Forms – Customizable Contact Forms, Survey, Quiz, & Conversational Form Builder Vendortechjewel Affected 5.1.16 – 6.1.1 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fluentforms:contact_form:*:*:*:*:*:*:*:* | — | — | Fluentforms |
- cpe:2.3:a:fluentforms:contact_form:*:*:*:*:*:*:*:* Versions — — ·Fluentforms
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9260
- 2026-10-03 Alias added: GHSA-hjqj-53jj-f33r
References
Other 3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/938e5d6b-1ad6-4021-a148-1d1c9e8a0a83?source=cve
- https://plugins.trac.wordpress.org/browser/fluentform/tags/6.0.2/app/Services/FormBuilder/EditorShortcodeParser.php#L214
- https://plugins.trac.wordpress.org/browser/fluentform/tags/6.0.2/vendor/wpfluent/framework/src/WPFluent/View/View.php#L7
More techjewel vulnerabilities
- TI-2024-08826 Deserialization of untrusted data in techjewel FluentSMTP – WP SMTP Plugin with Amazon… CVSS 3.1CRITICAL 9.8
- TI-2026-13364 Deserialization of untrusted data in techjewel Fluent Forms Pro Add On Pack CVSS 3.1HIGH 8.8
- TI-2026-04723 Fluent Forms <= 6.1.21 - Authenticated (Subscriber+) Authorization Bypass via 'form_id' Parameter CVSS 3.1HIGH 8.2
- TI-2026-04722 Fluent Forms <= 6.2.0 - Authenticated (Subscriber+) Authorization Bypass via 'table' Parameter CVSS 3.1HIGH 8.2
- TI-2026-02060 Fluent Forms Pro Add On Pack <= 6.1.17 - Missing Authorization to Unauthenticated Payment Status modification CVSS 3.1HIGH 7.5
- TI-2026-02001 Fluent Forms Pro <= 6.1.17 - Unauthenticated Stored Cross-Site Scripting via Draft Form Submission CVSS 3.1HIGH 7.2
Sources
- CVE-2025-9260 · CVE Program
- CVE-2025-9260 · NVD
- FIRST EPSS
- GHSA-hjqj-53jj-f33r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences